В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Помошь0
Помошь0
10.07.2022 14:00 •  Информатика

Впаскале, через case of составить программу для начисления зарплаты согласно следующему правилу: если стаж работы сотрудника менее 5 лет, то зарплата 50$., при стаже работы от 5 до 15 лет — 100$., при стаже свыше 15 лет зарплата повышается с каждым годом на 10$, превышающем 30 лет она составляет 300$

Показать ответ
Ответ:
dinaragappar
dinaragappar
09.10.2020 21:25

var

old:integer;

begin

writeln('Введите стаж');

readln(old);

case old of

0..4: writeln('50$');

5..15: writeln('100$');

16..30: writeln(100+(old mod 15)*10);

31..100: writeln('300$');

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота