В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Marka231
Marka231
12.07.2021 13:37 •  Информатика

Впаскале: 1.составить функцию и процедуру, которая определяет сумму всех чисел от 1 до n. 2.составить программу, которая определяет нод и нок двух чисел.

Показать ответ
Ответ:
Artishokq
Artishokq
30.06.2020 15:21
1)
program gt;
var n,s:integer;
procedure  summa(n:integer;var s:integer);
begin
s:=((n+1)*n)div 2;
writeln(s);
end;
begin
read(n);
summa(n,s);
end.
1.2)
program gt2;
var n,s:integer;
function summa(n:integer):integer;
var s:integer;
begin
s:=((n+1)*n)div 2;
summa:=s;
end;
begin
read(n);
s:=summa(n);
writeln(s);
end.
2)program gt;
label 3,9;
var m,n,q,r,a,b:longint;
begin
read(m,n);
a:=m;b:=n;
3:
q:=m div n;
r:=m mod n;
if (r=0)then goto 9;
m:=n;
n:=r;
goto 3;
9:
m:=(a*b)div n;
writeln('НОД=',n);
writeln('NOK=',m);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота