В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
anyutkavolf20
anyutkavolf20
21.09.2020 03:20 •  Информатика

Впаскаль абс. в эвм поступают результаты соревнований по плаванию для трех спортсменов. составьте программу, которая выбирает лучшей результат и выводит его на экран с сообщением, что это лучшей результат.

Показать ответ
Ответ:
yul19758694
yul19758694
12.06.2020 14:26

var i :integer;

     a, b:real;

begin

for i:=1 to 3 do

     begin

       write ('a=');

       readln(a);

      if (a>b) then b:=a;

     end;

writeln ('a=' , b);

end.

 

0,0(0 оценок)
Ответ:
SlonoMen
SlonoMen
12.06.2020 14:26

const
N = 3;

var
a: array[1..N] of integer;
i, max: integer;

begin
max := 0;
writeln('Введите результаты трех спортсменов');
for i := 1 to N do readln(a[i]);
for i := 1 to N do
begin
if a[i] > max then
max := a[i];
end;
writeln;
writeln('Лучший результат среди трех спортсменов - ', max);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота