В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
gulia2369
gulia2369
20.05.2022 10:22 •  Информатика

Вpascal написать программу, которая преобразует введенное с клавиатуры двухразрядное шестнадцатеричное число в десятичное.

Показать ответ
Ответ:
krubl
krubl
30.08.2020 20:15
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
  var s:=ReadlnString('Введите двухзначное 16-ричное число');
  var mH:array['A'..'F'] of integer:=(10,11,12,13,14,15);
  if s.Length=1 then s:='0'+s;
  var c:=s.ToCharArray;
  var n:=0;
  for var i:=0 to 1 do
    case c[i] of
    '0'..'9':n:=16*n+StrToInt(c[i]);
    'A'..'F':n:=16*n+mH[c[i]];
    else begin
      Writeln('Недопустимый символ: ',c[i]);
      Exit
      end
    end;
  Writeln('Десятичный эквивалент: ',n)
end.

Тестовое решение:
Введите двухзначное 16-ричное число 3A
Десятичный эквивалент: 58
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота