В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
дюха4004
дюха4004
19.05.2023 18:56 •  Информатика

Водномерном массиве а(к) хранятся результаты социологического опроса, напишите программу для подсчета кол-ва результатов отклоняющихся от среднего не более чем на 7% кол-во людей: 200. [0; 100]случайные числа( которые ставят люди). программа должна быть написанна для visual basic.

Показать ответ
Ответ:
тупикл12
тупикл12
11.06.2020 04:05

using System;
using System.Linq;

namespace Interesting {
    class Program {
        static void Main(params int[] a) {
            int n = 0;
            foreach (int i in a) {
                n += (Math.Abs(i - a.Average()) / 100 <= 0.07) ? 1 : 0;
            }
            Console.WriteLine(n);
        }
    }
}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота