Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Savich111
23.09.2022 17:32 •
Информатика
Вмассиве хранится информация о стоимости товаров. составьте программу, которая определяет стоимость самого дешёвого (дорогого) товара и его индекс
Показать ответ
Ответ:
даладно30раз
04.10.2020 02:23
#include <iostream>
int main(){ const int kol_tov = 20;
int sbol = 0; int sbol_index = 0; int smal = 0; int smal_index = 0;
int massiv[kol_tov] = { 12, 150, 1230, 332, 531, 1321, 32313, 123123, 123434, 4844, 84847, 48816, 181684, 181, 78616, 81141, 1894, 18974, 91234, 21239 };
smal = massiv[1];
for (int i = 0; i < kol_tov; i++) { if (massiv[i] > sbol) { sbol = massiv[i]; sbol_index = i + 1; } if (massiv[i] < smal) { smal = massiv[i]; smal_index = i + 1; } }
std::cout << "Samoe dorogoe: " << sbol << std::endl << "Samoe deshevoe: " << smal << std::endl << "Index dorogogo: " << sbol_index << std::endl << "Index deshevogo: " << smal_index << std::endl; system("PAUSE");}
0,0
(0 оценок)
Популярные вопросы: Информатика
Мarshmallow
24.11.2020 09:07
Составить программу, которая формирует массив из 15 случайных чисел принадлежащих промежутку [3,33]. нечетные числа заменяет на 1, а остальные увеличивает на 3. на экран...
qwertyuiop342
24.11.2020 09:07
Запишите шаблон для поиска файла имена которых: 1) name, а расширение имени файла произвольно 2) начинаются с буквы t и казанчиваются буквой k 3) произвольные, а расширение...
elenatsushko
30.12.2020 00:35
Напишите функцию в python, которая подсчитывает количество чётных и нечётных цифр в записи числа. , решить; )...
7Настася7
15.11.2022 08:33
Кто рисует в приложении ibispaint x! ! где находится эта конфиденциальность? (это не касается информатики)...
Mrt2004
08.04.2022 15:25
Два соседа, петя и вася, учатся в одном кружке. им дали написать сочи-нение, набрать его в текстовом редакторе и отправить преподавателю. у васи вдва раза больше символов...
HAHAEZ2010
12.10.2021 17:07
Втаблице запросы к поисковой системе. представьте результаты выполнения этих запросов графически с кругов эйлера. укажите обозначения запросов в порядке убывания количества...
dema1179
31.05.2022 01:02
Информационное сообщение объемом 2,5мбайт передается со скоростью 80кбайт/мин....
к1о2л3я4
31.05.2022 01:02
Решить в pascalabcnet. срок сдачи 21 октября 2017 г (составьте программу, которая проверяет оканчиваются ли вводимые числа на 5. составьте программу, которая проверяет:...
YanaNiki
16.09.2020 13:57
Необходимо нарисовать 57 одинаковых вертикальных палочек.Дан алгоритм .Выбери верный ответ. использовать Чертежник алг черточки 11 нач сместиться в точку (-4,3) нц ___...
wikkouiii
16.09.2020 13:57
напишите программу(Pascal), которая вычисляет произведение первых n членов ряда 1, ½, 1/3, ¼ Количество членов ряда задается во время работы программы (используя цикл...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
int main(){ const int kol_tov = 20;
int sbol = 0; int sbol_index = 0; int smal = 0; int smal_index = 0;
int massiv[kol_tov] = { 12, 150, 1230, 332, 531, 1321, 32313, 123123, 123434, 4844, 84847, 48816, 181684, 181, 78616, 81141, 1894, 18974, 91234, 21239 };
smal = massiv[1];
for (int i = 0; i < kol_tov; i++) { if (massiv[i] > sbol) { sbol = massiv[i]; sbol_index = i + 1; } if (massiv[i] < smal) { smal = massiv[i]; smal_index = i + 1; } }
std::cout << "Samoe dorogoe: " << sbol << std::endl << "Samoe deshevoe: " << smal << std::endl << "Index dorogogo: " << sbol_index << std::endl << "Index deshevogo: " << smal_index << std::endl; system("PAUSE");}