В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kistoria
kistoria
18.06.2021 03:41 •  Информатика

Вмассиве храниться информация о стоимости товаров. составьте программу, которая определяет стоимость самого дешевого товара и его индекс.

Показать ответ
Ответ:
napol2011
napol2011
23.05.2020 18:22

Массив данных о стоимости товаров зададим в виде целочисленных констант

program primer_1;
const a: array[1..12] of integer = (170, 180, 25, 36, 750, 1, 45, 28, 39, 10, 11, 58);
 i,min,k: integer;
 begin

min:=a[1]; 

for i:=2 to 12 do    if a[i]<min then

                                             begin 

                                              min:=a[i];
                                              k:=i;
write('минимальная стоимость ', min, '   индекс' ,k)
end.

Или скорее всего этот вариант

program primer_1;
var a: array[1..12] of integer;
i, min, k: integer;
begin
for i:=1 to 12 do read(a[i]);{Ввод стоимостей товаров}
min:=a[1];
k:=0;
for i:=2 to 12 do
if a[i]<min
then
begin
min:=a[i];
k:=i;
end;
write('мин. сто-мость ', min, ' индекс ' ,k)
end. 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота