Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
лиана250
17.06.2021 01:31 •
Информатика
Вмассиве целых чисел длины n требуется вычислить сумму элементов всех участков длины k. код просто с
Показать ответ
Ответ:
ikaerlapova
07.10.2020 03:57
#include <stdio.h>
#include <stdlib.h>
int main()
{
int n=10, k;
int a[n];
int max = 20, min = -20;
int sum=0;
printf("k (<=10) = "); scanf("%d",&k);
srand (time(NULL));
for (int i=0; i<n; i++) {
a[i] = (float) rand() / RAND_MAX*(max-min)+min;
printf ("%d ", a[i]);
}
printf("\n");
for (int i = 0; i<k; i++) sum+=a[i];
printf("sum (1..%d) = %d\n", k,sum);
for (int i=1; i<=n-k; i++) {
sum = sum-a[i-1]+a[i+k-1];
printf("sum (%d..%d) = %d\n", i+1, i+k, sum);
}
return 0;
}
Пример:
k (<=10) = 5-10 1 -11 -10 16 6 -1 -15 -19 9
sum (1..5) = -14
sum (2..6) = 2
sum (3..7) = 0
sum (4..8) = -4
sum (5..9) = -13
sum (6..10) = -20
0,0
(0 оценок)
Ответ:
Машка4155
07.10.2020 03:57
напишу толко алгоритм
while (I <n){
sum+=s;
s=0;
for (j=I; j <=k; j++){s+=mas [j];}
I++;
k++;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
artemgavrev
04.10.2021 07:41
До ть будь ласка з відповіддю....
суперкот78
16.06.2021 12:51
Паскаль. написать программу вычисления произведения n чисел то есть 1*2*3**n,причем, если n=0, то произведение равно 1.число множителей не должно превышать 33.при вводе...
Dasha2302
16.06.2021 12:51
Скорость передачи данных через adsl-соединение равна 256000 бит/с. передача файла через данное соединение заняла 40 с. каков объем файла в кбайтах ?...
irinaeenjoy
30.07.2020 18:34
1) операционная система.2)что такое1) операционная система. 2)что такое синтез. 3)выпишите все понятия которые есть в предложении; ветер по морю гуляет и кораблик подгоняет(пушкин)...
chernov5
12.08.2021 16:59
Https://videouroki.net/tests/proghrammirovaniie-linieinykh-alghoritmov-2.html решите тест по ссылке очень надо...
putnikputen
14.05.2020 03:32
Переведите одну единицу измерения в другие 1 байт = бит 128 бит =байт 1 Кбайт= бит1,5 Кбайт= ___байт2048 байт = ___ Кбайт2 Мбайт =Кбайт81920 бит = Кбайт 1,5 Мбайт = байт...
emilgasanov
19.09.2021 03:45
Диалог на казахском языке фаст фуд вреден...
enotic009
19.09.2021 03:45
Природное сообщества часто встречающееся в вашей местности в полевом...
ksenia915
19.09.2021 03:45
Составить предложения из этих слов (бас-шы,күз-дік,сызғыш,екілік,ойыншық,орындық,құлыншақ,кезекші,қойшы.) 30б...
rodionpanchenk
19.09.2021 03:45
Выпишите антонимы, определите их значение и структуру: в бричке сидел господин, не красивый, но и не дурной наружности, не слишком толст, ни слишком тонок; нельзя сказать,...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <stdlib.h>
int main()
{
int n=10, k;
int a[n];
int max = 20, min = -20;
int sum=0;
printf("k (<=10) = "); scanf("%d",&k);
srand (time(NULL));
for (int i=0; i<n; i++) {
a[i] = (float) rand() / RAND_MAX*(max-min)+min;
printf ("%d ", a[i]);
}
printf("\n");
for (int i = 0; i<k; i++) sum+=a[i];
printf("sum (1..%d) = %d\n", k,sum);
for (int i=1; i<=n-k; i++) {
sum = sum-a[i-1]+a[i+k-1];
printf("sum (%d..%d) = %d\n", i+1, i+k, sum);
}
return 0;
}
Пример:
k (<=10) = 5-10 1 -11 -10 16 6 -1 -15 -19 9
sum (1..5) = -14
sum (2..6) = 2
sum (3..7) = 0
sum (4..8) = -4
sum (5..9) = -13
sum (6..10) = -20
while (I <n){
sum+=s;
s=0;
for (j=I; j <=k; j++){s+=mas [j];}
I++;
k++;
}