Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Alllexxxsss
19.04.2022 14:07 •
Информатика
Вмассиве a[1..n] найти максимальное число и уменьшить все элементы массива на 5. вывести полученную последовательность на экран. !
Показать ответ
Ответ:
Алена0607
05.10.2020 13:44
// PascalABC.NET 3.2, сборка 1385 от 14.02.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),10,99); a.Println;
Writeln('Максимальный элемент равен ',a.Max);
a.Transform(x->x-5); a.Println;
end.
Пример
n= 15
30 73 60 94 45 83 32 11 47 25 44 71 95 60 90
Максимальный элемент равен 95
25 68 55 89 40 78 27 6 42 20 39 66 90 55 85
0,0
(0 оценок)
Популярные вопросы: Информатика
Liza5414755
18.01.2021 05:42
Visual Basic. Создать новый массив с элементами меньше 10 и больше -10, и найти суммы элементов старого и нового массивов....
НадеждаКрасюкова
22.10.2020 20:29
Написать программу в 1 файл паскаль Написать программу в 1 файл паскаль...
yaroslav9453
26.04.2021 04:57
Вычислить произведение и количество элементов массива а 10 для ai 0...
KristinkaVayyyys
03.09.2020 03:13
ОЧЕНЬ уровень как в Паскале решить????...
tom159753
05.12.2020 04:39
Переведите 436 из десятичной системы счисления в двоичную систему счисления. Сколько единиц содержит полученное число? в ответе Укажите одно число- количество единиц. С решением......
саша10041
04.02.2023 23:31
В дереве 4 потомка, и все они являются листьями. Нарисуйте это дерево. Сколько в нем вершин? ...
Влад847385
12.02.2021 11:37
ть написати в мові програмування Cбудь ласка, дуже потрібно...
bozenka20042004
08.02.2021 02:15
Символ = в мові програмування Python має назву: * рівність введення за присвоєння Оберіть приклад НЕВІРНОГО задання імені змінної: * 7_class _7class class_7 First Оберіть правильний...
Litegran
23.05.2020 15:36
Умооляю есле я ето не здам через 10 мин то жопа будет синяя моя бедная5 класс умоляю...
АлсушкаСушка
19.01.2022 10:53
Взят кредит на дом. Начальный взнос – 10%, он равен 300.000р. Кредит взят 01.06.2013. Кредит выплачивается ежемесячно, одинаковыми платежами. Проценты на кредит разные, в зависимости...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),10,99); a.Println;
Writeln('Максимальный элемент равен ',a.Max);
a.Transform(x->x-5); a.Println;
end.
Пример
n= 15
30 73 60 94 45 83 32 11 47 25 44 71 95 60 90
Максимальный элемент равен 95
25 68 55 89 40 78 27 6 42 20 39 66 90 55 85