Вмассив с клавиатуры вводятся результаты соревнований по многоборью 7 спортсменов (значениея результатов от 1000 до 2000 ). составить программу которая находит номер и результат победителя
Var A: array[1..7] of integer; i: byte; Max, MaxInd: integer; begin writeln('Заполнение массива. Вводите числа от 1000 до 2000.'); for i := 1 to 7 do begin write('A[',i,']='); readln(A[i]); if A[i] > Max then begin Max := A[i]; MaxInd := i; end; end; writeln; writeln('№ победителя ', MaxInd, ' результат = ', Max, ' .' ); end.
A: array[1..7] of integer;
i: byte;
Max, MaxInd: integer;
begin
writeln('Заполнение массива. Вводите числа от 1000 до 2000.');
for i := 1 to 7 do
begin
write('A[',i,']=');
readln(A[i]);
if A[i] > Max then
begin
Max := A[i];
MaxInd := i;
end;
end;
writeln;
writeln('№ победителя ', MaxInd, ' результат = ', Max, ' .' );
end.