В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Рома67463
Рома67463
17.10.2022 11:32 •  Информатика

Вклассе 20 учеников писали диктант по языку. напишите программу и начертите к ней блок-схему, подсчитывающую количество двоек, троек, четверок и пятерок за диктант. просто , 99 за программу и блок-схему.

Показать ответ
Ответ:
Fatima82
Fatima82
05.10.2020 00:29
Блок-схема - в прилагаемом файле. Программа:
const n=20;
var a:array[1..20] of integer;
i,k2,k3,k4,k5:integer;
begin
Randomize;
writeln('Оценки:');
for i:=1 to n do begin
 a[i]:=random(4)+2;
 write(a[i],' ');
 end;
writeln;
k2:=0;k3:=0;k4:=0;k5:=0;
for i:=1 to n do
 case a[i] of
  2: k2:=k2+1;
  3: k3:=k3+1;
  4: k4:=k4+1;
  5: k5:=k5+1;
 end;
writeln('Двоек: ',k2);
writeln('Троек: ',k3);
writeln('Четверок: ',k4);
writeln('Пятёрок: ',k5);
end.

Пример:
Оценки:
3 5 3 2 5 3 2 5 3 4 4 5 2 3 3 4 4 2 2 5 
Двоек: 5
Троек: 6
Четверок: 4
Пятёрок: 5
Вклассе 20 учеников писали диктант по языку. напишите программу и начертите к ней блок-схему, подсчи
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота