В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
18larina18
18larina18
07.07.2020 06:19 •  Информатика

Вкладчик внес в сберкассу x рублей. написать программу,вычисляющую,сколько денег будет у него через n лет. кол-во денег каждый год увеличивается на 3 % по отношению к предыдущему году.

Показать ответ
Ответ:
Ангелина75645674
Ангелина75645674
28.05.2020 00:30

program test;
var years: integer; contribution: real;
begin
   write('Enter the contribution sum: ');
   readln(contribution);
   write('Enter the number of years: ');
   readln(years);

   while years <> 0 do
   begin
      contribution:=contribution+(contribution / 100 * 3);
      years:=years-1;
   end;

   writeln(contribution:0:2, ' rub');

   readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота