В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
0005zet
0005zet
03.11.2022 21:09 •  Информатика

Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 1000 .

Выходные данные
Программа должна вывести элементы полученного массива в одной строке, разделив их пробелами.

Примеры
входные данные
6
6 2 1 5 3 4
выходные данные
1 2 3 6 5 4

Показать ответ
Ответ:
гребок
гребок
27.08.2022 17:52

Привет питонистам!

# - значок комментария, я использовала его, чтобы, если что, была возможность запустить код и свериться со всем в процессе

Вроде, примерно я всё описала, но если что-то не до конца понятно, можешь спрашивать!! Код действительно не самый тривиальный, но, вроде, это одна из реализаций merge sort или сортировки слиянием

Насколько я понимаю, в результате вызова этой подпрограммы мы проходимся по части массива (с элемента под номером p и до последнего) и при этом постоянно сравниваем элементы из двух частей от этой части массива - левой и правой. Таким образом, если у нас mass = {6, 3, 5, 1, 2, 7}, p = 0, q = 2, r = 5

Получаем left = {6, 3, 5}, right = {1, 2, 7}

И, проходясь по циклу while, получаем следующие значения:

1-ая итерация цикла: 6 > 1 => mass = {1, 3, 5, 1, 2, 7}

2-ая: 6 > 2 => mass = {1, 2, 5, 1, 2, 7}

3-я: 6 < 7 => mass = {1, 2, 6, 1, 2, 7}

4-я: 3 < 7 => mass = {1, 2, 6, 3, 2, 7}

5-я: 5 < 7 => mass = {1, 2, 6, 3, 5, 7}

Затем наш цикл заканчивается, так как просмотрены все элементы массива left, но, так как мы не поставили на место последний элемент массива right, запустится самый нижний цикл. Нам повезло и семёрка уже стоит на своём месте, но программа перепишет её ещё раз

Итог первого прохода программы: mass = {1, 2, 6, 3, 5, 7}

Как мы видим, произошла частичная сортировка, но, чтобы полностью отсортировать массив, требуется больше одного подхода и сходу весь алгоритм я написать не смогу - если это нужно, напиши и я попробую разобраться через какое-то время

# def - слово, говорящее нам о том, что перед нами подпрограмма/функция

# Атрибуты:

# mass - некоторый массив чисел

# p, q, r - некоторые значения. Имеет смысл вводить такие, что p <= q < r

def Merge(mass, p, q, r):

# Вводим массив left: это новый массив, включающий в себя с p-ого по (q+1)-ый элементы массива mass

left = mass[p : q + 1]

# Вводим массив right: это новый массив, включающий в себя с (q+1)-ого по (r+1)-ый элементы массива mass

right = mass[q + 1 : r + 1]

# i, j, k - традиционные наименования переменных циклов

i, j, k = 0, 0, p

# len() - функция для подсчёта количества элементов в массиве

# Соответственно, цикл выполняется до тех пор, пока не будут просмотрены все элементы в массиве left или все - в массиве right

while i < len(left) and j < len(right):

 # Вначале мы проверяем, больше ли i-ый элемент массива left j-ого в массиве right

 if left[i] < right[j]:

  # Если да, заменяем k-ый элемент массива i-ым элементом массива left

  mass[k] = left[i]

  # И прибавляем к i единицу, чтобы сдвинуть цикл

  i += 1

 else:

  # Если нет, заменяем k-ый элемент массива j-ым элементом массива right

  mass[k] = right[j]

  # И сдвигаем j на единицу

  j += 1

 # После этого, вне зависсимости от результата условия, сдвигаем k

 k += 1

# Затем, так как есть шанс, что элементы в каком-то из массивов не просмотрены до конца, проверяем массивы

# Если программа не до конца массива left, она перекладывает все элементы из него в массив mass

while i < len(left):

 mass[k] = left[i]

 i += 1

 k += 1

# Если программа не до конца массива right, она перекладывает все элементы из него в массив mass

while j < len(right):

 mass[k] = right[j]

 j += 1

 k += 1

0,0(0 оценок)
Ответ:
Keeping
Keeping
28.08.2020 14:48

import java.io.*;

import java.util.Scanner;

class Password{

   private String name;

   public String getName() {

       return name;

   }

   public void setName(String name) {

       this.name = name;

   }

   public Password(String name){

       this.name = name;

   }

   public boolean check(){

       boolean letter = false, number = false;

       for(int i = 0; i < name.length(); i++){

           if(name.charAt(i) >= '0' && name.charAt(i) <= '9')

               number = true;

           else if((name.charAt(i) >= 'a' && name.charAt(i) <= 'z') || (name.charAt(i) >= 'A' && name.charAt(i) <= 'Z'))

               letter = true;

       }

       return (letter && number && name.length() > 12);

   }

}

public class Main {

   public static void main(String[] args){

       Scanner sc = new Scanner(System.in);

       String testPassword;

       System.out.println("Input your password: ");

       testPassword = sc.nextLine();

       Password password = new Password(testPassword);

       if(password.check()) System.out.println("Your passwrod is correct");

       else System.out.println("Your password is incorrect");

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота