В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Vovanik212
Vovanik212
02.11.2020 06:54 •  Информатика

Вести n чисел и найти среднее арифметическое. написать программу и нарисовать блок схему.

Показать ответ
Ответ:
mikhaillukashc
mikhaillukashc
18.09.2020 13:58
#include <iostream>
using namespace std;
 int main(){
setlocale(LC_ALL,"Rus");
int N,dp,S,F,d;
S=0;F=0;d=0;
while(S<1){
cout<<"Выберите действие"<<endl;
cout<<"1.Ввод чисел"<<endl;
cout<<"2.Подсчет среднего арифметического"<<endl;
cout<<"Выполнить действие-";
cin>>dp;
switch(dp){
case 1:
cout<<"Введите число ";
cin>>N;
F=F+N;
d++;
break;
 case 2:
S=(float)F/d;
break;
}
}
cout<<"Среднее арифметическое="<<S<<endl; system("pause"); 
   return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота