В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Охико14
Охико14
25.10.2022 17:12 •  Информатика

Верно ли, что сумма всех отрицательных членов заданного массива по модулю больше, чем сумма всех положительных членов. составить программу

Показать ответ
Ответ:
aculkow2017
aculkow2017
05.10.2020 06:51
Const n=10; 
var a:array[1..n] of integer;
i,s1,s2:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(51)-25;
 write(a[i]:4);
 end;
writeln;
s1:=0; s2:=0;
for i:=1 to n do
 if a[i]<0 then s1:=s1+a[i] else s2:=s2+a[i];
writeln('s1 = ',s1,' s2 = ',s2);
if abs(s1)>s2
 then writeln('Yes, |',s1,'| > ',s2)
 else writeln('No, |',s1,'| <= ',s2);
end.

Пример:
Массив A:
  -3  16   5 -14 -14  -4 -13 -25  13  16
s1 = -73 s2 = 50
Yes, |-73| > 50
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота