В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Svetlana2675
Svetlana2675
01.10.2020 14:41 •  Информатика

Вдумерном массиве хранится информация о заплате 20 человек за каждый месяц года (первого человека - в первой строке, второго - во второй и т.д ). составить программу для расчета общей зарплаты , полученной за год любым человеком , информация о зарплате которого представлена в массиве. код программы для с++

Показать ответ
Ответ:
MrWolf1244
MrWolf1244
21.04.2022 17:14
На Java:

class SearchPalin{
 public static void main(String args[]){
  String palinString = new java.util.Scanner(System.in).nextLine();
  System.out.print("\nПалиндром(-ы):\n  ");
  for(int wordStart = 0, wordEnd = 0; wordEnd<palinString.length(); wordEnd++)
   if(wordEnd+1==palinString.length() || palinString.charAt(wordEnd+1)==' '){
 String wordBeginning = "", wordEnding = "";
 for(int wordBe = wordStart;wordBe<wordEnd+1;wordBe++)wordBeginning+=palinString.charAt(wordBe);
 for(int wordEn = wordEnd;wordStart-1<wordEn;wordEn--)wordEnding+=palinString.charAt(wordEn);
 if(wordBeginning.equals(wordEnding)){
  for(int palinWord = wordStart;palinWord<=wordEnd;palinWord++)System.out.print(palinString.charAt(palinWord));
  System.out.print("\n  ");
 } wordStart = wordEnd+2;
   }
 }
}
0,0(0 оценок)
Ответ:
grange
grange
21.04.2022 17:14
// PascalABC.NET 3.0, сборка 1139 от 10.01.2016
begin
  var s:=ReadLnString('Вводите:');
  s.ToWords.Where(x->x=ReverseString(x)).PrintLn;
end.

Тестовое решение:
Вводите: дед иван достал наган и пошел с ним в шалаш
дед наган и с в шалаш

Вариант, если исключить однобуквенные:

// PascalABC.NET 3.0, сборка 1139 от 10.01.2016
begin
  var s:=ReadLnString('Вводите:');
  s.ToWords.Where(x->x=ReverseString(x)).
    Where(x->x.Length>1).PrintLn;
end.

Тестовое решение:
Вводите: дед иван достал наган и пошел с ним в шалаш
дед наган шалаш
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота