В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
МариКэт1
МариКэт1
19.01.2022 23:05 •  Информатика

Ваша задача — написать программу, которая переводит число во время в читабельном виде. Пользователь должен ввести число больше 0 и меньше 8639999.

Число необходимо перевести в день, часы, минуты и секунды.

Ну и дополнительной задачей является — забота о выводе.

Слово "день" подбирается на основе кол-ва дней, а часы, минуты и секунды должны заполняться

нулями при одноцифровых значениях.

Пример:

0 -> 0 дней, 00:00:00

224930 -> 2 дня, 14:28:50

466289 -> 5 дней, 09:31:29

8639999 -> 99 дней, 23:59:59

22493 -> 0 дней, 6:14:53

7948799 -> 91 день, 23:59:59

Показать ответ
Ответ:
spiridon
spiridon
01.04.2023 19:44

Первая строчка спрашивает у человека адрес файла. После ввода получается подобная строчка: "C:\Users\usr\password.txt"

Но там есть такая штука ".split('/')"

Суть её в том, что она разделяет строку и суёт части в массив. В скобках пишется сам разделитель. Если в скобках ничего нет, то разделителем служит пробел. Если выполнить

'hello world guys yes no'.split()

то получим в итоге массив

['hello', 'world', 'guys', 'yes', 'no']

В твоём случае разделителем служит "/". Если ты хотел разделить адрес на составляющие, нужно использовать слеш в другую сторону.

Тут строчка

'C:\Users\usr\password.txt'.split('/')

превратиться в

['C:\Users\usr\password.txt']

То есть не разделиться.

Я думаю задумывалось вот так:

'C:\Users\usr\password.txt'.split('\')

выйдет

['C:', 'Users', 'usr', 'password.txt']

Будем отталкиваться от моего варианта.

Далее идёт цикл for. В нашем случае в цикле for "i" будет равна числу от 0, до кол-ва объектов в массиве.

len(a) - даёт кол-во объектов в массиве.

in range - проходит по числам в определенном диапазоне. Если стоит одно число, то проходится от 0 до него (если число 3, то проходится по числам 0,1,2). Если два числа, то проходится от первого до второго с шагом один (если числа 2 и 5, то проходится по числам 2,3,4). Третье число (все числа записываются через запятую) будет означать шаг. in range(0,40,10) пройдётся по числам 0, 10, 20, 30.

В нашем случае in range проходится по кол-ву объектов в массиве.

В следующей строчке выводится "a[i]". a - это наш массив. i -  порядковый номер объекта в массиве (стоит помнить, что массив начинает счёт не с 1, а с 0. Т. е. 0 объект - это первый объект.)

Если в код засунуть путь до файла, то в итоге он тебе выведет каждую часть путя.

Если C:\Users\usr\password.txt, то код напишет

C:

Users

usr

password.txt

Пиши, если есть вопросы.

0,0(0 оценок)
Ответ:
cat159753jjyfvb
cat159753jjyfvb
11.12.2020 16:20

Відповідь:

#include <iostream>

using namespace std;

const int size = 4;

void inputarr(int *arr,const int size){

for(int i = 0 , counter = 1; i < size; i++, counter++){

 cout << "Введите " << counter << " число: ";

 cin >> arr[i];

}

}

void sortarr(int *arr,const int size){

for(int i = 0; i < size - 1; ++i){

 int biggest = i;

 for(int j = i + 1; j < size; ++j){

  if(arr[j] > arr[biggest]){

   biggest = j;

  }

 }

 

 swap(arr[i],arr[biggest]);  

}

}

void printarr(int *arr,const int size){

for(int i = 0; i < size; i++){

 cout << arr[i] << " ";

}

}

int main(){

setlocale(LC_ALL, "Rus");

int arr[size];

inputarr(arr,size);

cout << "Изначальное положение: ";

printarr(arr,size);

cout << "\nРезультат: ";

sortarr(arr,size);

printarr(arr,size);

return 0;

}

Использовал одномерный массив и сделал сортировку методом выбора по убыванию

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота