Вариант 7 1. составьте программу закрашивания буквы "т", размерами четыре клетки по вертикали и три по горизонтали. начальное положение робота - где-то в центре поля. 2. необходимо перевести робота из начального положения (◊) в точку a за минимальное число шагов любым из возможных кумир - исполнитель робот - перевести робота - 7-1 3. необходимо перевести робота по лабиринту из начального положения (◊) в точку a. кумир - исполнитель робот - перевести робота - 7-2
1. Берілген нүктелер арқылы өтетін түзудің теңдеуін жазыңыз: А(2;1) В(-1;2). [2 ұпай]
2. Шеңбердің берілген теңдеуі бойынша оның центрінің координаталары мен радиусын табыңыз: (х-4)2 +(у+8)2 =36 [1 ұпай]
3. нүктелері берілген.
a) төбелерінің координаталары бойынша салыңыз; [1 ұпай]
b) қабырғаларының ұзындықтарын табыңыз; [3 ұпай]
c) түрін анықтаңыз (теңқабырғалы, теңбүйірлі, тікбұрышты); [2 ұпай]
d) берілген үшбұрыштың ауданын есептеңіз. [2 ұпай]
4. Төбелері А (1;-1) В (0;1) С (4;3) және Д (5;1) нүктелері болатын төртбұрыштың тіктөртбұрыш болатынын дәлелдеп, оның ауданын табыңыз. Ол үшін:
a) төбелерінің координаталары бойынша сызбасын салыңыз; [1 ұпай]
b) қабырғаларының ұзындықтарын табыңыз; [4 ұпай]
c) диагональдарын анықтап, дәлелдеңіз; [2 ұпай]
d) тіктөртбұрыштың ауданын есептеңіз. [2 ұпай]
Объяснение
begin
writeln("введите количество метров пробегания жирафа");
read(y1);
writeln("введите, за сколько секунд он должен пробежать");
read(x1);
writeln("введите количество метров пробегания зайца");
read(y2);
writeln("введите, за сколько секунд он должен пробежать");
read(x2);
v1:=y1/x1;
v2:=y2/x2;
if v1>v2 then
begin
writeln("жираф чемпион");
end
else if v1<v2 then
begin
writeln("заяц чемпион");
end
else
begin
writeln("победила дружба);
end;
end;