Вариант 6 Напишите программу ввода одномерного массива случайных чисел с интервала (-50; 50), состоящего из N элементов (N задается константой, не более 100 элементов) Выведите в строчку в зонном формате. На картинке пример как надо записать только с теми числами которые в задании , сейчас урок закончится скоро
Логическое «ИЛИ» ложно только тогда, когда ложны оба высказывания. Преобразуем выражение: (число <= 50) ИЛИ (число чётное) и проверим все варианты ответа.
Истинно, поскольку истинны оба высказывания:
40, 42, 44, 46, 48, 50.
Истинно, поскольку истинно первое высказывание:
41, 43, 45, 47, 49 не больше 50.
Истинно, поскольку истинно второе высказывание:
52, 54, 56, 58, 60. — чётное.
Ложно, поскольку ложны оба высказывания:
51, 53, 55, 57, 59.
Складываем числа которые являются ложным высказыванием условия:
using System;
namespace ConcoleApplication
{
class Program
{
public static void Main()
{
var n = int.Parse(Console.ReadLine());
var input = Console.ReadLine().Split();
var maxUneven = 0;
var index = 0;
for (var i = 0; i < n; i++)
{
var elem = int.Parse(input[i]);
if (elem % 2 != 0 && elem > maxUneven)
{
maxUneven = elem;
index = i;
}
}
Console.WriteLine(index);
}
}
}
Объяснение:
сделал ввод массива в одну строку
Логическое «ИЛИ» ложно только тогда, когда ложны оба высказывания. Преобразуем выражение: (число <= 50) ИЛИ (число чётное) и проверим все варианты ответа.
Истинно, поскольку истинны оба высказывания:
40, 42, 44, 46, 48, 50.
Истинно, поскольку истинно первое высказывание:
41, 43, 45, 47, 49 не больше 50.
Истинно, поскольку истинно второе высказывание:
52, 54, 56, 58, 60. — чётное.
Ложно, поскольку ложны оба высказывания:
51, 53, 55, 57, 59.
Складываем числа которые являются ложным высказыванием условия:
51 + 53 + 55 + 57 + 59 = 275
ответ: 275