В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
tvoyamamka7
tvoyamamka7
09.06.2021 23:18 •  Информатика

Вариант 1
1. напишите программу. одномерный массив а[1..n] заполнен
0 и 1, расположенными в произвольном порядке. перефор-
мируйте массив так, чтобы сначала шли элементы, равные
0, а затем — 1. предусмотрите вывод исходного и перефор-
мированного массивов на экран.
запишите текст программы:
- - - - - - - - - - - - - -
-
- - - - - - - - - - -

Показать ответ
Ответ:
kisnasty951
kisnasty951
09.10.2020 01:25

var A:array[1..100000] of integer; i,k,i1,n:int64;

 begin

read(n);

 randomize;

  for i:=1 to n do

     A[i]:=random(2);

 writeln('Массив до переформировки:');

    for i:=1 to n do  

     write(A[i],' ');

 writeln;

 

for i1:= 1 to n do

 for i:=1 to n-1 do

   if A[i]>A[i+1] then begin k:=A[i]; A[i]:=A[i+1]; A[i+1]:=k; end;

     

     writeln('Массив после переформировки:');

    for i:=1 to n do  

     write(A[i],' ');

       

      end.

   

     

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота