В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
муза2007
муза2007
26.01.2023 13:21 •  Информатика

Вам дан массив из n целых чисел. вы должны найти в этом массиве минимум и максимум, после чего подсчитать их усреднённое значение. формат входных данных в первой строке входных данных находится одно натуральное число n (n≤105) — количество элементов в массиве. во второй строке находятся n целых чисел, не превышающих по модулю 109 — элементы массива. формат выходных данных требуется вывести усредненное значение минимума и максимума. примеры входные данные 5 7 2 1 8 5 выходные данные 4.5

Показать ответ
Ответ:
нэлли1987
нэлли1987
26.05.2020 09:45

И что тут сложного?

#include <iostream>

using namespace std;

int main()

{

   int n;

   

   cin >> n;

   

   int32_t arr[n];

   

   for (size_t i = 0; i < n; ++i)

   {

       cin >> arr[i];

   }

   

   int32_t max = arr[0], min = arr[0];

 

   for (auto &i : arr)

   {

       if (i > max) max = i;

       if (i < min) min = i;

   }

   

   cout << static_cast<float>(max + min) / 2 << "\n";

   

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота