В программе Кумир Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 6. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 6.
ответ:ОБЪЯВЛЕНИЕ МАССИВА
Массивы в Паскале используются двух типов: одномерные и двумерные.
Определение одномерного массива в Паскале звучит так: одномерный массив — это определенное количество элементов, относящихся к одному и тому же типу данных, которые имеют одно имя, и каждый элемент имеет свой индекс — порядковый номер.
Описание массива в Паскале (объявление) и обращение к его элементам происходит следующим образом:
Описание массива в Паскале
Объявление массива
var dlina: array [1..3] of integer;
begin
dlina[1]:=500;
dlina[2]:=400;
dlina[3]:=150;
...
dlina — идентификатор (имя) массива;
для объявления используется служебное слово Array (в переводе с англ. «массив» или «набор»);
[1..3] — в квадратных скобках ставится номер (индекс) первого элемента, затем две точки и индекс последнего элемента массива, т.е. по сути, указывается количество элементов; количество элементов массива называется размерностью массива
of integer (с англ. «из целых чисел») — указывает, к какому типу относится массив, of здесь — служебное слово.
Объявить размер можно через константу:
размер массива через константу
ИНИЦИАЛИЗАЦИЯ МАССИВА
Кроме того, массив может быть сам константным, т.е. все его элементы в программе заранее определены. Описание такого массива выглядит следующим образом:
const a:array[1..4] of integer = (1, 3, 2, 5);
Заполнение последовательными числами:
заполнение массива
Результат:
A[1] = 8, A[2] = 9, A[3] = 10, ..., A[N] = A[N-1] + 1
Ввод с клавиатуры:
Пример: Рассмотрим, как происходит ввод массива в Паскале:
writeln ('введите кол-во элементов: ');
readln(n); {если кол-во заранее не известно, - запрашиваем его}
for i := 1 to n do begin
write('a[', i, ']=');
read(a[i]);
...
end;
...
Объяснение:
1 Аполлон - божество солнца, сын Зевса и Лето, а все остальные планеты
2. Флейта - духовный инструмент, а остальные струнные
3. Рикша - это повозка, а остальные название морских судов
4. Тургенев - писатель, а остальные композиторы
5. Нью-Йорк - город, а все остальные столицы
6. бунгало, иглу, шале - это жилье, причем тут осень и зима
7. Нил - река в африке, а остальные в Европе
8. Руслан - название самолета, остальные название авто
9. Торф - минерал, остальные твердые ископаемые
10. Кофе - мужского рода, остальные среднего рода