В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Waleri2579
Waleri2579
21.01.2020 21:07 •  Информатика

В питоне! Ввести с клавиатуры натуральное число и найти сумму значений его цифр.
Пример:
Введите число:
1234
Cумма цифр 10
Составьте программу для питона

Показать ответ
Ответ:
Ахамад
Ахамад
14.12.2020 12:02

number = int(input("Введите число: "))

amount = 0

while number > 0:

   amount += number % 10

   number //= 10

print("Сумма цифр =", amount)

Объяснение:

number = int(input("Введите число: ")) # Ввод целочисленного значения с клавиатуры

amount = 0 # Переменная, хранящая сумму, равна 0

while number > 0: # Пока значение переменной number > 0

   amount += number % 10 # // Суммируем последнюю цифру от числа

   number //= 10 # // Отделяем эту цифру

print("Сумма цифр =", amount) # // Выводим ответ

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота