В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
АлисаAprel
АлисаAprel
08.02.2022 00:51 •  Информатика

В массиве хранится информация о стоимости книг . Составить программу, которая выводит на экран номера книг, которые стоят ниже средней стоимости всех этих книг. В C++

Показать ответ
Ответ:
барев34
барев34
14.10.2020 23:22

#include <iostream>

using namespace std;

#define ll long long

#define ld long double

signed main(){

   ll n;

   cin >> n;

   ld a[n],sum = 0;

   for(ll i = 0; i < n; i++){

       cin >> a[i];

       sum += a[i];

   }

   ld av = sum/n;

   for(ll i = 0; i < n; i++)

       if(a[i] < av)

           cout << i+1 << " ";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота