В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Dayana2005041
Dayana2005041
03.04.2023 12:36 •  Информатика

Уровень c. напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи. уровень d (на дополнительную оценку, не обязательная). напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли в его десятичной записи одинаковые цифры, стоящие рядом.

Показать ответ
Ответ:
AnutaNikishina
AnutaNikishina
05.10.2020 15:46
Уровень C

#include <iostream>

using namespace std;

int main()
{
    int n;
    cin >> n;
    int maxdigit = 0;
    while (n > 0) {
        int digit = n % 10;
        if (digit > maxdigit)
            maxdigit = digit;
        n /= 10;
    }
    cout << maxdigit;
    return 0;
}

Уровень D
#include <iostream>

using namespace std;

int main(){
    int n;
    cin >> n;
    int prev = -1;
    while (n > 0) {
        int digit = n % 10;
        if (digit == prev) {
            cout << "YES";
            return 0;
        }
        prev = digit;
        n /= 10;
    }
    cout << "NO";
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота