Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
dania45451
20.05.2021 00:18 •
Информатика
Уровень A. Напишите программу, которая заменяет в символьной строке все точки на нули и все буквы X на единицы. Пример:
Введите строку: ..X.XX.
Двоичный код: 0010110
На Пайтоне сделайте
Показать ответ
Ответ:
Ram543
13.12.2020 06:29
While (tnum != 0) //tnum, tden - числитель и знаменатель искомой дроби
{
if (tnum < tden)
{
temp = tnum;
tnum = tden;
tden = temp;
}
tnum = tnum - tden;
}
gcd = tden; //вычисляем наибольший общий делитель
numerator = numerator / gcd; //делим числитель и знаменатель на
НОД, получаем сокращенную дробь
denominator = denominator / gcd;
0,0
(0 оценок)
Ответ:
evgenijpetrov
08.03.2023 07:22
Vara,b,c,d,x1,x2: real;
begin
writeln('Дано уравнение вида ax^2+bx+c=0');
Writeln ('Укажи переменную "a"');
readln(a);
Writeln ('Укажи переменную "b"');
readln(b);
Writeln ('Укажи переменную "c"');
readln(c);
if a = 0
then writeln('Не квадратное уравнение!')
else begin
d:= sqr(b)-4*a*c;
if d < 0 then writeln('Нет корней')
else begin
x1:= (-b+sqrt(d))/2*a;
x2:= (-b-sqrt(d))/2*a;
writeln ('X1 =',x1,' X2 =',x2);
end;
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
FayaKuraeva
22.11.2022 05:23
Встудии при двухканальной (стерео) звукозаписи с 32-битнымразрешением за 150 секунд был записан звуковой файл. сжатие данных непроизводилось. известно, что размер файла оказался не...
ryzhofftosha20
03.10.2020 12:26
Запишите команду присваивания, в запишите команду присваивания, в результате выполнения которой логическая переменная t получает значение true, если выполняется указанное условия,...
Даша29911
06.02.2022 01:00
Опишите историю создания электронной почты. Приведите примеры электронных почтовых сервисов, покажите на скриншотах....
exm0r3d
10.02.2022 18:22
1. Камера делает фотоснимки размером 250 × 300 пикселей. На хранение одного кадра отводится 40 Кбайт. Найдите максимально возможное количество цветов в палитре изображения. 2. Какой...
Настя0857
18.09.2022 04:18
Составить программу для решения , используя цикл «до». условие : написать программу подсчета суммы s первых 1000 членов гармонического ряда 1+1/2+1/3+1/4+/n...
metalnikovat
23.03.2022 12:59
Найди ошибку и выпиши её. кузнечик,муха,паук,жужелица-насекомые....
IdaPosion
23.03.2022 12:59
Решили .вычисли и запиши ответ каждой . а)при покупки 4 пачек масла заплатили 256 руб. сколько стоят 7 таких пачек? сколько стоят 8 таких же пачек?...
MaykTV26
23.03.2022 12:59
Исправьте речевые ошибки в данных предложениях. объясните причины их возникновения: 1)работники больницы знали, кто в них бросает камешки. 2)я много работал,чтобы получить образование,...
bandit12341
23.03.2022 12:59
Подготовить выборочное изложение на тему слушаем пение дрозда начать изложение можно так в тишине вечернего леса на самую маковку ели взлетает певчий дрозд и начинает внимание: всё...
Luda2600
23.03.2022 12:59
Втреугольнике абс биссектрисы углов а и б пересекаются под углом 91 градус. чему равен угол?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
{
if (tnum < tden)
{
temp = tnum;
tnum = tden;
tden = temp;
}
tnum = tnum - tden;
}
gcd = tden; //вычисляем наибольший общий делитель
numerator = numerator / gcd; //делим числитель и знаменатель на
НОД, получаем сокращенную дробь
denominator = denominator / gcd;
begin
writeln('Дано уравнение вида ax^2+bx+c=0');
Writeln ('Укажи переменную "a"');
readln(a);
Writeln ('Укажи переменную "b"');
readln(b);
Writeln ('Укажи переменную "c"');
readln(c);
if a = 0
then writeln('Не квадратное уравнение!')
else begin
d:= sqr(b)-4*a*c;
if d < 0 then writeln('Нет корней')
else begin
x1:= (-b+sqrt(d))/2*a;
x2:= (-b-sqrt(d))/2*a;
writeln ('X1 =',x1,' X2 =',x2);
end;
end;
end.