В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kulisenok
kulisenok
01.03.2021 20:18 •  Информатика

УМОЛЯЮ
задание 1.
Составить блок-схему алгоритма и программу на Паскале для вычисления функций z. Ввести программу в ЭВМ, вычислить значения функции и проверить ее для самостоятельно выбранных трех пар значений переменных X и Y. (рисунок снизу)
задание 2.
Составить блок-схему алгоритма и программу для обработки массива из 20 чисел X = (0,3; 5; 69; –3; 52; –20; –9; –23; –9; 10; 36; 12; 15; 23; –0,2; –36; –0,3; 8; 45; –7) при b = –6 Вычислить произведение и количество элементов, не равных нулю и больших b.

задание 3.
Составить программу и блок-схему алгоритма для вычисления площади 5 квадратов со сторонами, изменяющимися от 0 до 15 в цикле.

В отчет включить текст программ на Паскале, реакции ЭВМ.

Показать ответ
Ответ:
erkenova0909
erkenova0909
07.08.2022 07:51
 1.
#include <iostream> //если не отображается, пиши после include - iostream в <>
 using namespace std;

 int main(){
  for(int i=0;i<10;i++)
         cout<<"Hello World";
  cin.get();
  cin.get();
  return 0;
 } 11.
#include <iostream> //если не отображается, пиши после include - iostream в <>
#include <string> //если не отображается, пиши после include - string в <>
using namespace std;
int main() {
string s,p;
         cin>>s;
         cin>>p;
         if((p!="v") && (p!="g"))
         return 66;
         int n;
         cin>>n;
         if (p=="g"){
          for(int i=0;i<n;i++)
          cout<<s;
         }
         else
         {
          for(int i=0;i<n;i++)
          cout<<s<<"\n";
         }
         cin.get();
         cin.get();
return 0;
}
0,0(0 оценок)
Ответ:
Миша75040406
Миша75040406
13.12.2022 09:25
Целая часть от деления                    Остаток от деления12 div 2 = 6                                        12 mod 2 = 06 div 2 = 3                                          6 mod 2 = 03 div 2 = 1                                          3 mod 2 = 11 div 2 = 0                                          1 mod 2 = 1Остаток от деления записываем в обратном порядке. Получаем число в 2-ой системе счисления: 1100
12 = 1100|2
Для перевода дробной части числа последовательно умножаем дробную часть на основание 2. В результате каждый раз записываем целую часть произведения.
0.75*2 = 1.5 (целая часть 1)
0.5*2 = 1 (целая часть 1)
0*2 = 0 (целая часть 0)
0*2 = 0 (целая часть 0)
Получаем число в 2-ой системе счисления: 1100
0.75 = 1100|2
В итоге получаем число: 1100.1100|2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота