В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
gleb090902
gleb090902
20.04.2023 17:42 •  Информатика

У вас есть массив чисел длиною "N". Нужно найти XOR всех чисел. Входные данные:

(1 ≤ n ≤ 10000), где каждый элемент в массиве в промежутке (-10000 ≤ a[i] ≤ 10000)

Выходные данные:

Выведите XOR всех чисел

Пример 1
Ввод:
10
71 39 83 41 67 55 89 5 45 77

Вывод:
82

Показать ответ
Ответ:
yastremskayaal
yastremskayaal
02.09.2020 02:07

pascal

Объяснение:

var

 a: array [1..21] of integer;

 i, max, imax: integer;

begin

 randomize;

 WriteLn('Исходный массив:');

 for i := 1 to 21 do

 begin

   a[i] := random(66) - 13;

   Write(a[i], ', ');

 end;

 WriteLn;

 WriteLn('Результат задания 1:');

 for i := 1 to 21 do

 begin

   if i mod 2 = 0 then a[i] := -3 * a[i];

   Write(a[i], ', ');

 end;

 WriteLn;

 WriteLn('Результат задания 2:');

 for i := 1 to 21 do

 begin

   if a[i] < 10 then a[i] := - a[i];

   Write(a[i], ', ');

 end;

 WriteLn;

 max := -13;

 WriteLn('Результат задания 3:');

 for i := 1 to 21 do

 begin

   if abs(a[i]) > 40 then a[i] := a[i] - 15;

   Write(a[i], ', ');

   if a[i] > max then

   begin

     max := a[i];

     imax := i;

   end;

 end;

 WriteLn;

 a[imax] := sqr(imax);

 WriteLn('Результат задания 4:');

 for i := 1 to 21 do

   Write(a[i], ', ');

end.

0,0(0 оценок)
Ответ:
irazatula05
irazatula05
19.10.2021 20:52
Средняя глубина Черного моря — 1271 м, наибольшая- 2245 метров (вблизи Синопа). Протяженность моря между западной и восточной точками —около 1167 км, между северной и южной-624 километра. Наименьшая протяженность акватории в меридиональном направлении, между Крымом и берегом Анатолии (азиатской части Турции), 263 км. Длина береговой линии Черного моря — 4090 км, коэффициент изрезанности — около 1,8.На площади, занятой Черным морем, можно разместить две Великобритании. Азовское море соединяется с Чёрным морем Керченским проливом. Площадь его — около 38000 кв. км. Преобладающие глубины — 9-13 м, наибольшая — 14,5 м. Берега изрезаны слабо. Крупнейший залив - Таганрогский; у западного берега - система мелких заливов Сиваш. Южный берег моря холмистый, для северного и северо-восточного берегов характерны косы. В Азовское море впадают реки Дон, Кубань и другие, образуя лиманы. Климат континентальный, средняя температура воздуха летом +23?-24?, зимой -7 ?С. С конца декабря до конца февраля покрывается льдом. Течения неустойчивы. Вода отличается мутностью, море богато рыбой: судак, лещ, кефаль, осётр, и т. д. Главные порты: Ростов-на-Дону, Таганрог, Азов.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота