В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
jjiki
jjiki
25.07.2022 10:32 •  Информатика

У нас есть бизнес-план! Пункт первый: надо написать программу-гороскоп, которая по некоторым простым вопросам выдаёт строго индивидуальный анализ личностных качеств. Мы будем делать это по передовым астрологическим методикам. Напишите программу, которая считывает с клавиатуры последовательно: имя, фамилию, любимое животное, знак зодиака.

После этого программа выводит:

Индивидуальный гороскоп для пользователя [имя] [фамилия]
Кем вы были в жизни: [любимое животное]
Ваш знак зодиака - [знак зодиака] , поэтому вы - тонко чувствующая натура.

Уточнение: слова про тонко чувствующую натуру выводятся абсолютно всегда, независимо от того, что именно вводил пользователь (это пародия на процесс составления «реального» гороскопа). В один и тот же фиксированный текст подставляются те слова, которые вводил пользователь.

Пробел перед запятой по правилам, конечно, не ставится, но здесь пусть стоит.

Пример
Ввод Вывод
Иван
Кузнецов
лис
овен
Индивидуальный гороскоп для пользователя Иван Кузнецов
Кем вы были в жизни: лис
Ваш знак зодиака - овен , поэтому вы - тонко чувствующая натура.
История решений
Добавить комментарий

Показать ответ
Ответ:
NastyaCat21
NastyaCat21
05.07.2021 11:27

Program a10;

var a,b:Array [1..100,1..100] of integer;

k,i,n,j,s:integer;

Begin

read(n);

For i:=1 to n do

begin

For j:=1 to n do

begin

read(a[i,j]);

end;

end;

i:=0;j:=0;s:=0;k:=0;

while i<=n do

begin

i:=i+1;j:=j+1;

if(a[i,j]>0)then k:=k+1;

s:=s+a[i,j];

end;

writeln(k,' ',s);

end.

2)

Program a10;

var a,b:Array [1..100,1..100] of real;

k,i,n,m,j:integer;

s:real;

Begin

read(n,m);

For i:=1 to n do

begin

For j:=1 to m do

begin

read(a[i,j]);

end;

end;

k:=0;

for j:=1 to m do

begin

s:=0;

for i:=1 to n do

begin

s:=s+a[i,j];

end;

for i:=1 to n do

begin

if(a[i,j]>(s-a[i,j]))then k:=k+1;

end;

end;

writeln(k);

end.

0,0(0 оценок)
Ответ:
Алина113111
Алина113111
07.01.2020 22:08
Program egor_sasha; var num_eg, num_sash,pri,pri1: real; var mes_eg,mes_sash: real; beginwriteln('numer egora'); readln(num_eg); writeln('numer sashi'); readln(num_sash); writeln('mesto egora (verkh=1,vniz=0)'); readln(mes_eg); writeln('mesto sashi (verkh=1,vniz=0)'); readln(mes_sash); pri: =num_sash+1; pri1: =num_eg+1; if num_eg=pri then    writeln('yes')  else writeln('no'); if num_sash=pri1 then    writeln('yes')  else writeln('no'); if mes_eg=1 then    writeln('egor-high')else  writeln('egor-low'); if mes_sash=1 then    writeln('sasha-high')else  writeln('sasha-low'); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота