В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

у меня сессия Написать программу, которая в текстовом файле заменит все
вхождения одного заданного слова на другое заданное слово
4.

Показать ответ
Ответ:
irazatula05
irazatula05
19.10.2021 20:52
Средняя глубина Черного моря — 1271 м, наибольшая- 2245 метров (вблизи Синопа). Протяженность моря между западной и восточной точками —около 1167 км, между северной и южной-624 километра. Наименьшая протяженность акватории в меридиональном направлении, между Крымом и берегом Анатолии (азиатской части Турции), 263 км. Длина береговой линии Черного моря — 4090 км, коэффициент изрезанности — около 1,8.На площади, занятой Черным морем, можно разместить две Великобритании. Азовское море соединяется с Чёрным морем Керченским проливом. Площадь его — около 38000 кв. км. Преобладающие глубины — 9-13 м, наибольшая — 14,5 м. Берега изрезаны слабо. Крупнейший залив - Таганрогский; у западного берега - система мелких заливов Сиваш. Южный берег моря холмистый, для северного и северо-восточного берегов характерны косы. В Азовское море впадают реки Дон, Кубань и другие, образуя лиманы. Климат континентальный, средняя температура воздуха летом +23?-24?, зимой -7 ?С. С конца декабря до конца февраля покрывается льдом. Течения неустойчивы. Вода отличается мутностью, море богато рыбой: судак, лещ, кефаль, осётр, и т. д. Главные порты: Ростов-на-Дону, Таганрог, Азов.
0,0(0 оценок)
Ответ:
khavakim
khavakim
07.05.2022 21:38
Значит так: мы создаем массив избыточной длины, куда потом будем записывать рандомные числа. Так же мы создаем массив-счетчик b (у него индексами являются сами числа, а элементами - количество этого числа в массиве А), куда будет присваиваться, сколько раз нам встречается то или иное число (перед этим мы массив обязательно обнулим). В конце мы смотрим максимальное число из массива-счетчика. Вуаля!

Вот пример программы на паскале ABC:

var a:array [1..1000000] of integer; 
b:array [1..10] of longint;   
c:integer;   
i,max,n:longint;
begin
write('Введите число элементов массива: ');
readln(n); 
max:=0; 
for i:=1 to 10 do 
b[i]:=0; 
for i:=1 to n do  begin 
a[i]:=random(10)+1; 
write(a[i],' '); 
b[a[i]]:=b[a[i]]+1 
end; 
for i:=1 to 10 do if b[i]>max then 
begin 
c:=i; 
max:=b[i] 
end; 
writeln; 
writeln('Чаще всего в массиве встречается число ',c)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота