В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Требуется написать программу, которая выводит скорость и время движения автомобиля и выводит на экран расстояние, которое он проехал. Определите входные данные и результат этого алгоритма. К какому типу относятся входные данные:
Выберите элемент.
Сколько входных значений у алгоритма?

К какому типу относятся результаты:
Выберите элемент.
Сколько результатов у алгоритма?

Обозначьте именами входные данные и результаты и напишите их на стрелках:
алгоритм

Запишите формулу, которая связывает исходные данные и результат:

Показать ответ
Ответ:
LizaLove200468
LizaLove200468
28.10.2021 04:57

# подключаем библиотеку, чтобы использовать случайные числа

from random import randint  

n=int(input('Введите количество элементов массива : '))# вводим размерность массива

a=[0]*n # Создаём массив размерность n

for i in range (0, n):  #в цикле  

 a[i]=randint(1,30)   # заполняем каждый элемент случайными числави

print(a)  #печатаем исходный массив

a=sorted(a)# сортируем исходный массив

print(a) # печатаем отсортированный массив

x=int(input('Введите Х :')) #вводим Х

for i in range (n-1, 1, -1): # в цикле

 if x > a[i]:                # ищем положение, куда вставить X

   a[n-1]=a[n-1]+a[i]   # к максимальному элементу массива прибавляем #элемент который заменили

   a[i]=x    # а на его место вставляем Х

   break

print(a) # печатаем ответ


Заполнить массив случайными числами и отсортировать его ввести число x. python желательно с коммента
0,0(0 оценок)
Ответ:
Max325t
Max325t
04.02.2020 14:18

У мові програмування Object Pascal є кілька команд, які можуть реалізувати цикл. Одна з них - команда циклу з лічильником. Її доцільно використовувати в тих випадках, коли кількість повторень команд тіла циклу відома ще до початку виконання команди циклу. Загальний вигляд цієї команди такий:

for <ім’я змінної> := <вираз1> to <вираз2> do begin  <команди тіла циклу> end;

Рядок for <ім’я змінної> := <вираз1> to <вираз2> do (англ. for - для, to - до, do - робити, виконувати) називають рядком заголовка команди циклу з лічильником. Змінну в рядку заголовка команди циклу з лічильником, що стоїть перед знаком присвоювання, називають лічильником циклу.  Лічильник циклу, виразі і вираз2 мають набувати тільки цілих значень. Якщо тіло циклу складається лише з однієї команди, операторні дужки begin і end можна не ставити.

Виконується команда циклу з лічильником так:

1) Надати лічильнику циклу і значення виразі.

2) Обчислити значення логічного виразу і J вираз2.

3) Якщо значення логічного виразу true, то виконати команди тіла циклу і перейти до виконання команди 4, якщо false - перейти до виконання команди, наступної за командою циклу.

4) Збільшити значення лічильника циклу на 1.

5) Перейти до виконання команди 2.

Для ілюстрації виконання команди циклу з лічильником розглянемо фрагмент проекту, в якому обчислюється сума 12 + 22 + 32 + 42.

var s, і: integer; begin s := 0;

for і := 1 to 4 do begin

s := s + i*i; end;

Labell.Caption := IntToStr (s); end;

Виконаємо цей фрагмент програми.

Команда     Результат виконання

s := 0              s = 0

i := 1                 i = 1

i <= 4              (1 <= 4) = true

s := s + i*i        s = 0 + 1*1 = 1

i := i + 1            i = 2

i <= 4              (2 <= 4) = true

s := s + i*i        s = 1 + 2*2 = 5

i := i + 1            i = 3

i <= 4              (3 <= 4) = true

s := s + i*i        s = 5 + 3*3 = 14

i := i + 1            i = 4

i <= 4              (4 <= 4) = true

s := s + i*i        s = 14 + 4*4 = 30

i := i + 1            i = 5

i <= 4               (5 <= 4) = false

Labell.Caption := IntToStr (s)         Labell.Caption = 30

Звертаємо вашу увагу, що після закінчення виконання команди циклу з лічильником значення лічильника циклу (змінної і) на 1 більше, ніж значення вираз2, і це значення, за потреби, можна використовувати в наступних командах.

Існує різновид команди циклу з лічильником, у якому лічильник не збільшується на 1, а зменшується на 1:

For <ім’я змінної> := <вираз1> downto <вираз2> do begin

<команди тіла циклу> end;  (англ. down to - униз до).

Цей цикл продовжує виконуватися, якщо значення лічильника циклу більше або дорівнює (не менше) значенню вираз2.

Загальний вигляд команди циклу з лічильником такий:

for <ім’я змінної> := <вираз1> to <вираз2> do begin

<команди тіла циклу> end;

Рядок for <ім’я змінної> := <вираз1> to <вираз2> do називають рядком заголовка команди циклу з лічильником. Змінну в рядку заголовка команди циклу з лічильником, що стоїть перед знаком присвоювання, називають лічильником циклу. Лічильник циклу, виразі і вираз2 мають набувати тільки цілих значень.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота