В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
cucumber03
cucumber03
30.08.2022 04:51 •  Информатика

Требовалось написать программу вычисления факториала числа n (факториал числа n есть произведение всех целых чисел от 1 до n). программист торопился и написал программу неправильно. ниже фрагмент его программы, в котором содержится пять ошибок: к : = 1; f : = 0; while k f: =f * k; к: =к + 1 найдите ошибки. допишите необходимые операторы и выполните программу на компьютере. пример входных данных пример входных данных пример выходных данных введите n> 5 5! =120 введите n> 6 6! =720

Показать ответ
Ответ:
svetasan76
svetasan76
22.09.2020 18:50
Var n,k,f:integer;
begin
write('n='); readln(n);
k:=1;
f:=1;
while k<=n do
 begin f:=f*k; k:=k+1; end;
writeln(n,'!=',f);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота