Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел, а и b хотя бы одно четное. Была написана следующая программа:
var a, b: integer;
begin
readln(a, b);
a := a mod 2;
if a > 0 then b := b mod 2;
if b > 0 then
writeln ('четных чисел нет')
else
writeln ('четное число есть');
end.
Известно, что программа написана с ошибками. Последовательно выполните три задания:
приведите пример таких чисел, а, b, при которых программа неверно решает поставленную задачу;
укажите, как, по вашему мнению, нужно доработать программу (не используя сложные условия), чтобы не было случаев ее неправильной работы;
укажите, как можно доработать программу, чтобы она вместо вложенных операторов IF содержала один условный оператор со сложным условием.
Объяснение:
Анализом доходов и расходов занимается каждый человек, которому небезразлично финансовое благополучие своей семьи. Если вы не знаете сколько у вас денег значит их у вас нет. Ведение бюджета позволяет всегда оставаться в плюсе, предупреждать ненужные траты, реализовывать цели и мечты.
Готовых программ для учета доходов и расходов много. Но найти лучшую программу, которая выполняла бы все запросы конкретной семьи сложно. Ведь запросы-то разные. Предлагаем составить семейный бюджет в Excel и адаптировать его под свои нужды.
Бүгінгі таңда локалды желінің кабельдік жүйесінің сапасынан қалыспайтын, жоғары жылдамдықты аумақтық арналар байланысының пайда болуымен, ауқымды және локалды желі арасында айырмашылық күннен күнге азаюда. Ауқымды желіде локалды желі қызметі сияқты қорларға кірудің тиімді және қолайлы қызметі пайда болды. Осындай мысалдар көп мөлшерде өте белгілі Ethernet ауқымды желісінде көрсетіледі. Локалды желі де өзгереді. Компьютерлерді біріктіретін белсенді емес кабельдің орнына көп мөлшерде әртүрлі коммуникациялық құрылғылар – коммутаторлар, маршруттаушылар, шлюздер пайда болды. Осындай құрылғының арқасында өте күрделі құрылымы бар және мыңдаған компьютерді есептейтін үлкен корпоративті желіні құруға мүмкіндік туды.
Объяснение:
100% дурыс жауап отинем лайк