В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nadezhstepan20
nadezhstepan20
12.06.2022 05:05 •  Информатика

Тема: знакомство с языком паскаль
1 уровень сложности и
1. а) набрать в редакторе системы турбо-паскаль следующую программу:
program my;
var a,b,c,s: integer;
begin
readln(a);
readln(b);
readln(c);
s: =a*b*с;
writeln(s)
end.
6) откомпилировать набранную программу и исправить ошибки.
в) запустить данную программу на выполнение и проверить правильность ее ра-
боты для чисел 2, 4 и 6.
г) запустить данную программу на выполнение и проверить правильность её рабо-
ты для чисел 1, ои-1.
д) запустить данную программу на выполнение и проверить правильность ее ра-
боты для чисел -2, зи 10.
2. написать программу, которая присваивает целой переменной а значение 10 и
выводит это значение на экран.
3. написать программу, которая запрашивает ввод целого числа в переменную в и
выводит это число на экран. проверить правильность работы программы на числах 1, -
5, 256, 10455.
4. написать программу, которая запрашивает ввод вещественного числа в пере-

Показать ответ
Ответ:
spirt708ozrmv0
spirt708ozrmv0
06.02.2021 03:38
Выполняя алгоритм, получаем следующий результат (15 итераций)

1. 0..65534 -> 32767
2. 0..32766 -> 16383
3. 0..16382 -> 8191
4. 0..8190  -> 4095
5. 0..4094  -> 2047
6. 2048..4094 -> 3071
7. 2048..3070 -> 2559
8. 2560..3070 -> 2815
9. 2816..3070 -> 2943
10. 2944..3070 -> 3007
11. 2944..3006 -> 2975
12. 2976..3006 -> 2991
13. 2992..3006 -> 2999
14. 3000..3006 -> 3003
15. 3000..3002 -> 3001

Если лень перебирать вручную, можно воспользоваться программой

var k,l,r,x,f:integer;
begin
f := 3001;
l := 0;
r := 65534;
x := (l + r) div 2;
k := 1;
while (x <> f) and (l < r) do
  begin
  writeln(k,' ',l,' ',r,' ',x);
  k := k + 1;
  if f < x then r := x - 1
    else l := x + 1;
  x := (l + r) div 2
  end;
writeln(k,' ',l,' ',r,' ',x);
end.
0,0(0 оценок)
Ответ:
rgugalinskaya16
rgugalinskaya16
08.05.2020 15:54

1) это сведения о чём то

2)обоняние , осязание, зрение , слух.

3) Блок питания

— Центральный процессор

— Внешняя видеокарта (ее разъем PCI, AGP, PCI-Express)

— Оперативная память

— Оптический DVD привод

— Трехдюймовый дисковод гибких дисков (FDD 3,5)

— Жесткий диск (винчестер)

— Материнская плата (фиолетовая)

4) Основными устройствами вывода являются монитор, принтер, плоттер акустические колонки, наушники.

5) Backspace

6) PageDown

7) это то что содержит и хранит информацию

8) клавиатура

9) Сканер

10) клавиатуре, Диска, принтере или на бумагу

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота