В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
janneellz
janneellz
16.08.2021 20:00 •  Информатика

(тема Python) Кролик Клевер и принцесса София нашли рецепт вишневого варенья. Рецепт вишневого варенья достаточно прост: "Для варенья возьмите вишню, сахар и воду в соотношении 3:2:1".
друзьям посчитать сколько получится варенья, если они возьмут воды в размере n литров (будем считать, что вода не выкипает). Сколько надо взять вишни и сахара?
Напишите для друзей программу, которая по введенному значению воды (n<=106) будет выводить, сколько надо взять вишни и сахара и сколько получится варенья.
Пример:
Входные данные
2
Выходные данные
water - 2 kg
cherry - 6 kg
sugar - 4 kg
jam - 12 kg
в примере должен быть "x"

Показать ответ
Ответ:
tropika33
tropika33
08.04.2020 11:38

ответ:1) (1 б.) Верные ответы: 3;

2) (1 б.) Верные ответы: 4;

3) (1 б.) Верные ответы: 1; 2;

4) (1 б.) Верные ответы: 3;

5) (1 б.) Верные ответы: 1;

6) (1 б.) Верные ответы: 3;

7) (1 б.) Верные ответы: 4;

8) (1 б.) Верные ответы: 1;

9) (1 б.) Верные ответы: 3;

10) (1 б.) Верные ответы: 3;

11) (1 б.) Верные ответы: 2;

12) (1 б.) Верные ответы: 3;

13) (1 б.) Верные ответы: 4;

14) (1 б.) Верные ответы: 1;

15) (1 б.) Верные ответы: 1; 2;

16) (1 б.) Верные ответы: 1;

17) (1 б.) Верные ответы: 2;

18) (1 б.) Верные ответы: 1;

19) (1 б.) Верные ответы: 3;

20) (1 б.) Верные ответы: 2;

21) (1 б.) Верные ответы: 2;

Объяснение:

0,0(0 оценок)
Ответ:
NeZnaiYProsto
NeZnaiYProsto
04.06.2023 05:44

#include <iostream>

using namespace ::std;

int main()

{

   setlocale(LC_CTYPE , "rus");

   

   int n, i, j = 0, k = 0;

   double s = 0;

   cout << "Введите количество элементов: \n";

   cin >> n;

   float x;

   float *massiv = new float[n];

   if (!massiv)

   {

       cout << "Сбой программы!\n";

       system("pause");

        return 0;

   }

   cout << "Введите массив с " << ' ' << n << ' ' << "элементов\n";

   for (i = 0; i < n; i++)

       cin >> *(massiv + i);

   cout << "Заданный массив: " << endl;

   for (int i = 0; i < n; i++)

       

       cout << *(massiv + i) << ' ' << endl;

 

   for (i = 0; i<n; i++)

   {

       if (massiv[i]>0)

           k++;

   }

   cout << " Количество положительных элементов = " << k << '\n';

 

 

   for (i = 0; i<n; i++)

   {

       if (massiv[i] == 0) {

           j = massiv[i];

           x = i;

       }

   }

 

   for (i = x; i<n; i++)

       s += massiv[i];

 

   cout << "Сумма =" << s;

   float *massiv2 = new float[n];

   if (!massiv2)

   {

       cout << "Сбой программы !\n";

       system("pause");

       return 0;

   }

   for (i = 0; i < n; i++)

       if (massiv[i] <= 1)

       {

           massiv2[j] = massiv[i];

           j++;

       }

 

   for (i = 0; i < n; i++)

       if (fabs(massiv[i]) > 1)

       {

           massiv2[j] = massiv[i];

           j++;

       }

   cout << endl << "Отсортированный массив: " << endl;

   for (int j = 0; j < n; j++)

       cout << '\n' << massiv2[j] << ' ';

 

   delete[] massiv;

   delete[] massiv2;

   system("pause");

   return 0;

}

В работо не сомневайся.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота