В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
baybiboom
baybiboom
06.08.2021 09:17 •  Информатика

Св паскале! написать решение для программы паскаль. ) имеется массив а из n произвольных чисел (а( среди которых есть положительные, отрицательные и равные нулю. используя оператор цикла, составить программу, выполняющую : найти номера первых двух рядом стоящих одинаковых элементов в массиве. например, если а={2,6,4,4,2,5,5,4}, результат: 3 и 4.

Показать ответ
Ответ:
Runalbert
Runalbert
29.06.2020 15:55
Program random_;
uses crt;
type
arr = array[0..1000] of shortint;
var
ar,b,i:word;
a:arr;
begin
randomize;
for ar:=0 to 999 do
a[ar]:= random(18)-9;

b:=10;
i:=0;
repeat b:=a[i]; i:=i+1; until(b = a[i]) or (i = 999);

if i = 999 then writeln('Повторяющихся чисел нет!') else writeln(i,' ',i+1) ;

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота