В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
1234567890825
1234567890825
25.09.2022 10:54 •  Информатика

Суммарный индекс паскал имя входного файла: стандартный ввод имя выходного файла: стандартный вывод ограничение по времени: 1 секунда ограничение по памяти: 256 мегабайт в параллельной вселенной винни — не просто медведь, а медведь-айтишник. летом он выбрал жертву, которая не может программировать, и дал ей возможность получить сообщение с готовым программным кодом от случайного человека из другой вселенной. этот человек — вы! для того, чтобы ему , вам нужно вывести элемент массива a на позиции, равной сумме позиций минимального и максимального элемента массива. ему. формат входных данных в первой строке вводится n (1 ⩽ n ⩽ 50) — количество чисел в массиве a. во второй строке вводится n чисел ai (0 ⩽ ai ⩽ 50) — элементы массива a. если максимальных или минимальных значений несколько, используйте первый из них. формат выходных данных выведите искомый элемент или строку «vne massiva», если искомый индекс выходит за границы массива. примеры стандартный ввод стандартный вывод 5 1 5 2 4 3 2 3 1 2 3 vne massiva 1 5 vne massiva

Показать ответ
Ответ:
olyabat
olyabat
20.01.2022 11:11
Var
    f: file of integer;
    i, n, x, t, k, max: integer;
    s: integer;

begin
    randomize;
    write('n=');
    readln(n);
    
    assign(f, 'numbers.dat');
    rewrite(f);
    
    max := -1;
    for i := 1 to n do
    begin
        x := random(4800) + 20;
        write(f, x);
        write(x, ' ');
        if x > max then max := x;
    end;
    writeln;
    
    seek(f, 0);
    k := 0;
    while not eof(f) do
    begin
        read(f, x);
        t := x;
        s := 0;
        while t > 0 do
        begin
            s := s + sqr(t mod 10);
            t := t div 10;
        end;
        if x mod s = 0 then k := k + 1;
        if x > max - 50 then write(x, ' ');
    end;
    writeln;
    
    writeln(k);
end.
0,0(0 оценок)
Ответ:
shvbur75
shvbur75
22.02.2021 03:03
4.Основные свойства алгоритмов следующие:

1.   Понятность для исполнителя — исполнитель алгоритма должен понимать, как его выполнять. Иными словами, имея алгоритм и произвольный вариант исходных данных, исполнитель должен знать, как надо действовать для выполнения этого алгоритма.

2.   Дискpетность (прерывность, раздельность) — алгоpитм должен пpедставлять пpоцесс pешения задачи как последовательное выполнение пpостых (или pанее опpеделенных) шагов (этапов).

3.   Опpеделенность — каждое пpавило алгоpитма должно быть четким, однозначным и не оставлять места для пpоизвола. Благодаpя этому свойству выполнение алгоpитма носит механический хаpактеp и не тpебует никаких дополнительных указаний или сведений о pешаемой задаче.

4.   Pезультативность (или конечность) состоит в том, что за конечное число шагов алгоpитм либо должен пpиводить к pешению задачи, либо после конечного числа шагов останавливаться из-за невозможности получить решение с выдачей соответствующего сообщения, либо неограниченно продолжаться в течение времени, отведенного для исполнения алгоритма, с выдачей промежуточных результатов.

5.Массовость означает, что алгоpитм pешения задачи pазpабатывается в общем виде, т.е. он должен быть пpименим для некотоpого класса задач, pазличающихся лишь исходными данными. Пpи этом исходные данные могут выбиpаться из некотоpой области, котоpая называется областью пpименимости алгоpитма.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота