В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
rege12345
rege12345
07.11.2021 01:58 •  Информатика

Сумма ряда Напишите программу, соблюдающие данные условия

C клавиатуры вводится натуральное число n > 0, потом n чисел, каждое на новой строке.

Вычислите и напечатайте знакочередующуюся сумму ряда (первое число прибавить, второе вычесть, третье прибавть и т.д.) Например, для чисел 1,2,3,4 сумма будет следующей: 1 - 2 + 3 - 4 = -2.

Пример 1

Ввод Вывод

3

5

2

7

10

Пример 2

Ввод Вывод

2

3

3

0

Пример 3

Ввод Вывод

5

34

-87

35

65

-9

82

Примечания

В задаче нельзя использовать условный оператор.

Показать ответ
Ответ:
29101975tanuxa
29101975tanuxa
21.11.2020 18:36

mstr = ""

for i in range(0, int(input())):

   while i % 2 == 0:

       mstr += "+" + input()

       break

   while i % 2 != 0:

       mstr += "-" + input()

       break

print(eval(mstr))

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота