В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
anuar0403
anuar0403
04.01.2022 06:17 •  Информатика

Сумма факториалов. КОД НУЖНО НАПИСАТЬ НА PYTHON.

По данному натуральном n вычислите сумму 1!+2!+3!+...+n!. В решении этой задачи можно использовать только один цикл.

Входные данные:

Вводится натуральное число n, не превосходящее 30.

Выходные данные:

Выведите ответ на задачу.

Примеры:

Ввод: 3
Вывод: 9

Показать ответ
Ответ:
артур613
артур613
10.07.2021 13:11

Відповідь:

Пояснення:

import math

n = int(input('число менше 30'))

s = 0

for i in range (1, n+1):

   m = math.factorial(i)

   s = s + m

print('1!+2!+3!+...+',n,'! = ',s)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота