В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
samokrut4501
samokrut4501
13.03.2022 18:35 •  Информатика

Студенту составить программу через pelles введите одномерный целочисленный массив, состоящий из 10-ти элементов. найдите сумму отрицательных элементов массива

Показать ответ
Ответ:
Dastannn1
Dastannn1
10.10.2020 12:03

#include <stdio.h>

#include <stdlib.h>

int main()

{

int Arr[10]={};// Создаем массив состоящий из 10 элементов.

int Summ = 0;// Переменная в которой будут храниться сумма отрицательных элементов массива

printf("Vvedite 10 elementov massiva \n");

for (int i = 0; i < 10; i++)

{

 

 scanf_s("%d", &Arr[i]);

 if (Arr[i] < 0)

 {

  Summ += Arr[i];

 }

}

printf("%d \n", Summ);

system("pause");

return 0;

}

0,0(0 оценок)
Ответ:
qqqqq9
qqqqq9
10.10.2020 12:03

/

                           Online C Compiler.

               Code, Compile, Run and Debug C program online.

Write your code in this editor and press "Run" button to compile and execute it.

/

#include <stdio.h>

int main()

{

   int m[10];

   int otrsumm = 0;

   int i;

   for (i = 0; i < 10; i++)

       scanf("%d", &m[i]);

   for (i = 0; i < 10; i++)

       if (m[i] < 0){

           otrsumm += m[i];

       }

   printf("%d", otrsumm);

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота