Stepik 2.1 шаг2 Напишите программу, которая в последовательности целых чисел определяет количество чисел, кратных 6.
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000.
Формат входных данных
Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).
Формат выходных данных
Программа должна вывести количество чисел, кратных 6.
НА ЯЗЫКЕ ПИТОН
program cgt;
var a:array[1..100,1..100]of integer;
s,n,m,i,j:integer;
begin
read(n,m);
s:=0;
for i:=1 to n do
for j:=1 to m do
read(a[i,j]);
for i:=1 to n do
begin
for j:=1 to m do
if(i mod 2=1)then s:=s+a[i,j];
end;
writeln(s);
end.
2)
program cgt;
var a:array[1..100,1..100]of integer;
n,m,i,j:integer;
s,p:real;
begin
read(n,m);
s:=0;
for i:=1 to n do
for j:=1 to m do
read(a[i,j]);
for i:=1 to n do
begin
p:=1;
if(i mod 2=0)then begin
for j:=1 to m do
begin
p:=p*(sin(a[i,j]*pi/180))/(cos(a[i,j]*pi/180));
end;
s:=s+p;
end;
end;
writeln(s);
end.
3)
program cgt;
var a:array[1..100,1..100]of integer;
n,m,i,j,max,x,y:integer;
begin
read(n,m);
for i:=1 to n do
for j:=1 to m do
read(a[i,j]);
max:=a[1,1];
for i:=1 to n do
if(i mod 2=1)then begin
for j:=1 to m do
if(a[i,j]>=max)then begin
max:=a[i,j];
x:=i;
y:=j;
end;
end;
writeln(x,' ',y);
end.