В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Mashavicks
Mashavicks
29.04.2022 23:31 •  Информатика

Stepik 2.1 шаг 3 из 10 Напишите программу, ко­то­рая в по­сле­до­ва­тель­но­сти целых чисел опре­де­ля­ет среднее значение чисел, кратных 6 и оканчивающихся на 4.

Количество чисел не пре­вы­ша­ет 1000. Введённые числа по мо­ду­лю не пре­вы­ша­ют 30 000. В числовом ряду обязательно есть число кратное 6 и оканчивающееся на 4.

Формат входных данных

Про­грам­ма по­лу­ча­ет на вход целые числа, ко­ли­че­ство введённых чисел неизвестно, по­сле­до­ва­тель­ность чисел за­кан­чи­ва­ет­ся чис­лом 0 (0 — при­знак окон­ча­ния ввода, не вхо­дит в последовательность).
Формат выходных данных

Про­грам­ма долж­на вы­ве­сти среднее значение чисел, кратных 6 и оканчивающихся на 4.​

Показать ответ
Ответ:
Лина230502
Лина230502
07.04.2023 00:50

# Задание 1

num = input('Введи целое число: ')

print('Количество цифр в числе = {}'.format(len(num)))

# Задание 2

from random import randint

print('Выпало {}'.format(randint(1, 6)))

# Задание 3

a = int(input('Введи 1 число: '))

b = int(input('Введи 2 число: '))

i = min(a, b)

while True:

   if i % a == 0 and i % b == 0:

       break

   i += 1

print(f'НОК = {i}')

# Задание 4

def fibonacci(n):

   a = 0

   b = 1

   if n < 0:

       print("Некорректный ввод!")

   elif n == 0:

       return a

   elif n == 1:

       return b

   else:

       for i in range(2, n):

           c = a + b

           a = b

           b = c

       return b

n = int(input('Введи N-ое число Фибоначчи: '))

print('Число Фибоначчи = {}'.format(fibonacci(n)))

Объяснение:

Python 3.8.2

0,0(0 оценок)
Ответ:
cleverprincess
cleverprincess
07.09.2022 21:13
Чертёж дан во вложении.
Пусть ΔABC - равнобедренный, АВ = с - его основание, АС = ВС = b - боковые стороны. По условию треугольник симметричен относительно горизонтальной оси, так что его основание АВ должно быть перпендикулярно горизонтальной оси и при этом АО = ОВ, а вершина С попадет на горизонтальную ось. Разместим ΔABC так, чтобы основание попало на вертикальную ось.
Окружность, описанная вокруг треугольника, пройдет через все три его вершины. Точка М - центр описанной окружности, - лежит на пересечении перпендикуляров, проведенных из середин сторон треугольника. Поскольку ΔABC равнобедренный, то ОС - его высота и отрезок МС, равный радиусу окружности R, также лежит на горизонтальной оси.
Найдем высоту ОС, обозначив её через h, по теореме Пифагора.
ОС - это катет ΔAOC, AO ⊥ OC.
\displaystyle h= \sqrt{AC^2-AO^2}= \sqrt{b^2-\left(\frac{c}{2}\right)^2}
Площадь ΔABC находим по формуле
\displaystyle S= \frac{1}{2}\cdot AB \cdot OC = \frac{1}{2}hc
Для нахождения радиуса R = MC рассмотрим прямоугольные ΔAOC и ΔMDC, имеющие общий угол АСО = α
\displaystyle \cos \alpha= \frac{OC}{AC}= \frac{CD}{MC} \to MC= \frac{AC\cdot CD}{OC}; \\ R= \frac{b\cdot \displaystyle \frac{b}{2}}{h} = \frac{b^2}{2h}; \qquad OM=h-R
Теперь легко сделать необходимое построение.
Для этого откладываем от начала координат по горизонтальной оси отрезок ОМ и проводим из него, как из центра, окружность радиуса R. Соединяем между собой три точки пересечения окружностью осей координат и получаем треугольник с длинами сторон, равными заданным.

Ниже приводится программа на языке Microsoft QBasic, позволяющая рассчитать длину отрезка ОМ (Mx - координату х точки М) и радиус описанной окружности R по заданной длине основания с и длине боковой стороны b.

INPUT "Основание: ", c
INPUT "Боковая сторона: ", b
h = SQR(b ^ 2 - (c / 2) ^ 2)
R = b ^ 2 / (2 * h)
Mx = h - R
PRINT "Радиус равен "; R, "Координата центра равна "; Mx

Тестовое решение:
Y:\qbasic>QBASIC.EXE
Основание: 6
Боковая сторона: 5
Радиус равен  3.125         Координата центра равна  .875

Чтобы продолжить, нажмите любую клавишу

(qbasic) построить равнобедренный треугольник симметричный относительно горизонтальной оси, задать е
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота