В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
apolo230kmn
apolo230kmn
23.07.2021 00:33 •  Информатика

Срешением двух ! . нужно написать программу на паскаль, заранее, ! ) в двумерном массиве 5 x 5, заполненный случайными числами, найти количество положительных элементовдан двумерный массив a[n,n]. сформировать одномерный массив в, состоящий только их элементов главной диагонали.

Показать ответ
Ответ:
Visiting456
Visiting456
07.07.2020 13:14
Var a: array[1..5,1..5] of integer;
pol,i,j:integer;
begin 
randomize;
for i:=1 to 5 do 
 for j:=1 to 5 do  a[i,j]:=random(100)-50;
for i:=1 to 5 do
  for j:=1 to 5 do  if a[i,j]>0 then inc(pol);
write(pol);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота