Сравнение дробей напишите программу, позволяющую сравнить две обыкновенные дроби. ввод на ввод подается четыре целых положительных числа (все числа не превышают 10 4 ): в первой строке числитель и знаменатель первой дроби, во второй строке числитель и знаменатель второй дроби. вывод если первая дробь меньше второй, выведите ‘< ’, если дроби равны, выведите ‘=’, если первая дробь больше второй,выведите ‘> ’. ввод вывод 1 2 3 4 < 17 34 1 2 = решить на паскаль
Внимание! Если программа не работает, обновите версию!
begin
var (a,b):=ReadlnInteger2; var (c,d):=ReadlnInteger2;
var k:=Sign(a*d-b*c);
Writeln(k>0 ? '>' : k=0 ? '=' : '<')
end.