Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
pchehov77
22.05.2021 03:38 •
Информатика
Сработой. напишите программу, которая вычисляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Показать ответ
Ответ:
ирина1523
03.10.2020 09:21
A) var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do s:=s+i;
writeln(s);
end.
б) var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do s:=s+(i*i);
writeln(s);
end.
в) var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do
begin
if (i mod 2 = 0) then s:=s+i;
end;
writeln(s);
end.
г) var s, i :integer;
begin
s:=0;
for i:= 10 to 99 do s:=s+i;
writeln(s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
brayamsp0altc
19.04.2023 20:26
Вариант 18 Переведи число 10111101, в десятичную систему счисления. Переведи число 101 в двоичную систему счисления. Выполни сложение 110101, и 100010002 Выполни вычитание...
yul19758694
18.04.2023 04:30
составить алгоритм ,, как я провел летние каникулы,, для 2 класса....
polix2008
23.06.2022 20:25
1. Дан двумерный массив А размерностью 5х5. Заполнить одномерный массив В по следующему принципу: если сумма очередной строки массива четная, то соответствующий элемент...
pitonpitonov
18.07.2021 05:50
Есть ли у кого-нибудь ключи из 2020 года для Сокровища Монтисумы 2? Я пытался нати генераторы, но ничего не работало......
zhannayachmenev
07.04.2020 17:38
Pascal/Дана следующая программа: var a,b,r:integer; begin readln(a,b); while b 0 do begin r:=a mod b; a:=b; b:=r; end; writeln(a); end. На вход программе переменной...
belokurserezhe
15.04.2023 03:31
Дан одномерный массив A размерности N. Найти сумму элементов, расположенных между максимальным и минимальным. Язык программирования VBA word...
snegjana
09.06.2020 06:13
Рассмотрим солнечную электростанцию как систему солнечных панелей. Для повышения выработки электроэнергии панель должна быть направлена в сторону солнца. Это означает,...
Аскарбинка25
05.02.2023 15:01
Составить блок-схему вычисления суммы синусов натуральных чисел от N до M....
SupercellTV
17.07.2020 17:42
сделать индивидуальные задания...
ася704
04.08.2020 01:06
3.4. Оператори управління 3.4.1. Оператори Оператори мови С поділяються на три групи: ·оператор-вираз; ·блок (складений оператор); ·оператор, що починається з ключового...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
s:=0;
readln(n);
for i:= 1 to n do s:=s+i;
writeln(s);
end.
б) var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do s:=s+(i*i);
writeln(s);
end.
в) var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do
begin
if (i mod 2 = 0) then s:=s+i;
end;
writeln(s);
end.
г) var s, i :integer;
begin
s:=0;
for i:= 10 to 99 do s:=s+i;
writeln(s);
end.