Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Сонякака332
05.01.2023 22:10 •
Информатика
Спо паскалю! (p.s. мы только начали цикл while) организован ввод чисел оканчивающихся нулём. посчитать сумму и количество чисел делящихся на a.
Показать ответ
Ответ:
ПолинаПадафет15
02.08.2020 23:14
Var
S:real;
A,C,N:integer;
Begin
N:=0;
S:=0;
Write('A = ');ReadLn(A);
WriteLn('Введите последоваельность чисел:');
Read(C);
While C <> 0 do
Begin
if C mod A = 0 then
Begin
S:=S+C;
N:=N+1;
End;
Read(C)
End;
WriteLn('S = ',S);
WriteLn('N = ',N);
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
deadloxSasha
09.04.2020 05:01
-На рисунке схема дорог Н-ского района изображена в виде графа, в таблице содержатся сведения о длине этих дорог в километрах. Так как таблицу и схему рисовали независимо друг...
saxarowaulia
20.09.2020 06:32
В странах А и В считают время по-разному. В одном часе в стране А ровно M 1 минут, а в одном дне ровно H 1 часов. В стране В в одном часе ровно M 2 минуты, а в одном дне ровно...
Darieva
25.05.2023 18:42
У нас есть 2 группы которые пишут сообщения. N1 -17 символ ьный алфавитN2- 32символаK1=100символовK2=50символов(сравнить объём данных сообщений)...
lizo4ka004
24.09.2022 09:58
Посмотри на коды чисел 2,4,8,16 и догадаеся какие коды у чисел 23,64...
лерка210198
17.07.2022 12:13
Дан код с номером. Определи, какой это символ: управляющий или изображаемый. Код с номером 55 изображаемый управляющий...
artemykas
29.03.2020 20:45
по инф. 6 номер 83стр 4 класс 2ч н.в матвеева: запиши свои размышления об управлении природой,плавательным стредствоом,СОБОЙ...
lilipute2017
07.08.2021 14:21
Написать программу на паскале рассматривается множество целых чисел, принадлежащих отрезку [200; 9120], которые делятся на 8 и не делятся на 7, 11, 17 и 19. Найдите количество...
Екатерина13250804
07.08.2021 14:21
очень Составить программу ,вычисляющую корни квадратного уравнения используя вложенные ветвления...
happycatcom
24.08.2022 14:55
Решить в целых числах уравнение ax + b = 0. входные данные вводятся 2 целых числа: a и b. выходные данные необходимо вывести все решения, если их число конечно, “no” (без кавычек),...
krusher77
23.11.2020 22:19
При каких значениях t двучлен 4t−14 принимает неотрицательные значения? Выбери правильный вариант ответа: другой ответ приt≤3,5 приt≥3,5 приt 3,5 приt≥−3,5 приt 3,5...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
S:real;
A,C,N:integer;
Begin
N:=0;
S:=0;
Write('A = ');ReadLn(A);
WriteLn('Введите последоваельность чисел:');
Read(C);
While C <> 0 do
Begin
if C mod A = 0 then
Begin
S:=S+C;
N:=N+1;
End;
Read(C)
End;
WriteLn('S = ',S);
WriteLn('N = ',N);
End.