В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Сpascal turbo. нужно написать программунаберите программу вычисления суммы s=x+x^2++x^n и проверьте ее работу при различных значениях x и натурального n

Показать ответ
Ответ:
amirak471
amirak471
03.10.2020 14:47
Var
  s, cur: longint;
  x, n, i: integer;
begin
  write('x='); read(x);
  write('n='); read(n);
  cur := 1; s := 0;
  for i := 1 to n do begin
    cur := cur * x; 
    s := s + cur;
  end;
  writeln('sum=', s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота