Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Angelina07111
01.05.2022 21:50 •
Информатика
Создайте программу, которая генерирует 20 случайных чисел в диапазоне от 1 до 15 , выводит эти числа на экран и вычисляет их сумму.
Показать ответ
Ответ:
Бетти2004
05.07.2020 04:48
Сначала - современное решение, каким оно должно быть:
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
SeqGen(ReadInteger('k=')+1,2.0,x->2+1/x).Skip(1).Println;
end.
Тестовое решение:
k= 6
2.5 2.4 2.41666666666667 2.41379310344828 2.41428571428571 2.41420118343195
А теперь "школьный вариант":
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
var
i,k:integer;
a,a0:real;
begin
Write('k='); Read(k);
a0:=2;
for i:=1 to k do begin
a:=2+1/a0; a0:=a; Write(a,' ')
end
end.
Тестовое решение:
k=6
2.5 2.4 2.41666666666667 2.41379310344828 2.41428571428571 2.41420118343195
0,0
(0 оценок)
Ответ:
kristinapaskan
02.02.2022 04:58
#include <iostream>
#include <sstream>
#include <vector>
#include <string>
using namespace std;
int main(int argc, char** argv) {
cout << "string: ";
string s; getline(cin, s);
istringstream ss(s);
vector<string> v;
while (ss >> s) v.push_back(s);
int j=v[0].size(),k=0;
for (int i=1; i<v.size(); i++)
if (v[i].size()>j) { j=v[i].size(); k=i; }
cout<<"long word: "<<v[k]<<endl<<endl;
system("pause");
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
tolodono
17.03.2021 04:02
Построить таблицу истинности для заданного логического выражения все задания...
Anya2k17
24.03.2022 01:10
Напишите алгоритм с аргументами для рисования фигуры, изображенной на рисунке. В качестве аргументов выступают размеры фигуры, указанные на рисунке.2. Начертите фигуру, изображенную...
redvellk7
01.07.2022 06:14
Кнопка для начала создания проекта ...
TlPuBeT
05.10.2022 14:47
Вы решили эффективно закодировать сообщение на латинице следующим образом: Каждой букве вы поставили в соответствие число от 1 до 26 в порядке возрастания. Каждому слову должно...
PavelSol
12.05.2023 06:17
Составьте программу, которая заполняет массив из 20 элементов случайными целыми числами от -50 до 50 и выводит на экран сначала все отрицателтные элементы, а затем все положительные...
LetMaria
28.10.2020 23:47
Какое устройство компьютера моделирует мышление человека? Выберите один ответ: дисплей память процессор клавиатура Как называется специальный блок, через который внешние устройства...
Гениально1
18.02.2021 00:25
Если один сервер за 5 с обрабатывает 4 млн запросов, то три сервера за 15 с обработают: *...
sofikolomiets04
28.02.2020 03:04
Чему равно значение вводимое на печать переменной? (phyton)...
nurganym1
04.11.2022 04:11
Сколько Мбайт потребуется для хранения графического изображения, занимающего весь экран монитора с разрешением 2048*1024 пикселей и палитрой из 256 цветов? В ответ запишите...
UbisCraft
03.05.2022 04:04
Поміркуйте, що дає підстави для поданого нижче висновку. Наведіть кілька аргументів на підтвердження або спростування думки. «Реформа 1861 р. вивільнила селян від особистої...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
SeqGen(ReadInteger('k=')+1,2.0,x->2+1/x).Skip(1).Println;
end.
Тестовое решение:
k= 6
2.5 2.4 2.41666666666667 2.41379310344828 2.41428571428571 2.41420118343195
А теперь "школьный вариант":
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
var
i,k:integer;
a,a0:real;
begin
Write('k='); Read(k);
a0:=2;
for i:=1 to k do begin
a:=2+1/a0; a0:=a; Write(a,' ')
end
end.
Тестовое решение:
k=6
2.5 2.4 2.41666666666667 2.41379310344828 2.41428571428571 2.41420118343195
#include <sstream>
#include <vector>
#include <string>
using namespace std;
int main(int argc, char** argv) {
cout << "string: ";
string s; getline(cin, s);
istringstream ss(s);
vector<string> v;
while (ss >> s) v.push_back(s);
int j=v[0].size(),k=0;
for (int i=1; i<v.size(); i++)
if (v[i].size()>j) { j=v[i].size(); k=i; }
cout<<"long word: "<<v[k]<<endl<<endl;
system("pause");
return 0;
}