В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
айдана152
айдана152
05.04.2020 11:14 •  Информатика

Создать программу python напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными. пример: введите два числа: 10 -15 10*(-15)=-150

Показать ответ
Ответ:
atalalihin
atalalihin
08.10.2020 00:30
A=int(input('a = '));
b=int(input('b = '));
if (((a<0) & (b>0)) | ((a>0) & (b<0))): sgn=1;
else: sgn=0;
if (a<0): a=-a;
if (b<0): b=-b;
c=0;
while (a>0):
    if ((a & 1)==1): c+=b;
    a>>=1;
    b<<=1;
if (sgn==1): print('результат: ',-c);
else: print('результат: ',c);

a = - 42153689754
b = 7892456310201
результат:  - 332696154697212539380554
    
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота