В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nicekuzia01
nicekuzia01
03.07.2020 12:15 •  Информатика

Составте в python. Даны целые числа a, b, с и d. Составьте программу вычисления произведения последних цифр суммы чисел а и b и разности чисел с и d. Чтобы ввод(код программы) соответствовал решению на рисунке. ​


Составте в python. Даны целые числа a, b, с и d. Составьте программу вычисления произведения последн

Показать ответ
Ответ:
kalinin11ccc
kalinin11ccc
18.03.2022 18:46
"Типовой школьный" Паскаль:

// PascalABC.Net 3.0, сборка 1064
const
  k = 100;

var
  s, wd: string;
  i, j, m, n, pt, step: integer;
  Words, WordsSort: array[1..k] of string;
  InOrder: boolean;

begin
  Write('Введите строку: '); Readln(s);
  n := Length(s); pt := 1; m := 0;
  repeat
    // Пропускаем все символы до первого непробельного
    while pt <= n do
      if Ord(s[pt]) <= 32 then Inc(pt) else break;
    if pt <= n then begin
      // Выделяем очередное слово
      wd := '';
      while pt <= n do
        if Ord(s[pt]) > 32 then begin wd := wd + s[pt];Inc(pt) end
        else break;
      if wd <> '' then begin Inc(m);Words[m] := wd end
    end
  until pt > n;
  // Теперь Words содержит все m слов.
  // Отсортируем их в массиве WordsSort методом Шелла
  for i := 1 to m do WordsSort[i] := Words[i];
  step := m div 2;
  while step > 0 do begin
    for j := m - step downto 1 do begin
      i := j;
      while i <= m - step do begin
        if WordsSort[i] > WordsSort[i + step] then begin
          wd := WordsSort[i];
          WordsSort[i] := WordsSort[i + 1];
          WordsSort[i + 1] := wd
        end;
        i := i + step
      end
    end;
    step := step div 2
  end;
  // Осталось поэлементно сравнить оба массива
  InOrder := true; i := 1;
  while InOrder and (i <= m) do
  begin InOrder := (Words[i] = WordsSort[i]); Inc(i) end;
  if m = 0 then Writeln('Строка не содержит слов')
  else
    if InOrder then Writeln('Cлова упорядочены')
    else Writeln('Cлова не упорядочены')
end.

Тестовое решение:
Введите строку: слово1    слово2    слово3    слово4 слово5
Cлова упорядочены

Введите строку: слово1    слово2    слово4    слово3 слово5
Cлова не упорядочены

"Современный" вариант решения на Паскале:

// PascalABC.Net 3.0, сборка 1064
var
  s:string;
begin
  Write('Введите строку: '); Readln(s);
  var Delim:=Range(0,32).Select(x->Chr(x)).ToArray;
  var Words:=s.Split(Delim).Where(x->x<>'');
  var WordsSort:=Words.Sorted;
  if Words.SequenceEqual(WordsSort) then Writeln('Cлова упорядочены')
  else Writeln('Cлова не упорядочены')
end.

Тестовое решение совпадает с вышеприведенным.
0,0(0 оценок)
Ответ:
MegaCrisp1
MegaCrisp1
01.01.2023 00:22
Вот программа : program xxx; 
<p>program xxx;</p><p>&nbsp;&nbsp; var i, k, d, e, s : integer;</p><p>begin</p><p>&nbsp; k:=0;</p><p>&nbsp;for i:= 10 to 99 do</p><p>&nbsp;&nbsp; begin</p><p>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; d:= i div 10;</p><p>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; e:= i mod 10;</p><p>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; s:=d + e;</p><p>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; if i mod s = 0 then k:=k+1</p><p>&nbsp;&nbsp; end;</p><p>&nbsp;&nbsp; write ('кол-во чисел которые делятся на сумму своих цифр=', k);</p><p>&nbsp;&nbsp; readln</p><p>end.</p>
Найдите количество двузначных чисел, которые делятся на сумму своих цифр.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота